aboutsummaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control26
1 files changed, 26 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 3f59548..f0f51ef 100644
--- a/debian/control
+++ b/debian/control
@@ -10,10 +10,13 @@ Build-Depends:
python-coverage (>= 3.4),
python-mock,
python-nose (>=1.1.2),
+ python-setuptools,
python-six,
python-tornado,
python3-all,
+ python3-setuptools,
python3-six,
+ python3-wheel,
Standards-Version: 3.9.5
X-Python-Version: >= 2.6
X-Python3-Version: >= 3.0
@@ -64,3 +67,26 @@ Description: HTTP library with thread-safe connection pooling for Python3
building upon.
.
This package contains the Python 3 version of the library.
+
+Package: python-urllib3-wheels
+Architecture: all
+Depends:
+ ${misc:Depends},
+ ${python3:Depends},
+ python3-six-wheels
+Recommends:
+ ca-certificates
+Description: HTTP library with thread-safe connection pooling
+ urllib3 supports features left out of urllib and urllib2 libraries.
+ .
+ - Re-use the same socket connection for multiple requests (HTTPConnectionPool
+ and HTTPSConnectionPool) (with optional client-side certificate
+ verification).
+ - File posting (encode_multipart_formdata).
+ - Built-in redirection and retries (optional).
+ - Supports gzip and deflate decoding.
+ - Thread-safe and sanity-safe.
+ - Small and easy to understand codebase perfect for extending and
+ building upon.
+ .
+ This package contains the universal wheels.