aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
-rw-r--r--debian/control3
-rw-r--r--debian/patches/01_do-not-use-python-certifi.patch21
3 files changed, 22 insertions, 12 deletions
diff --git a/debian/changelog b/debian/changelog
index a29feae..429b329 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+requests (0.12.1-1) unstable; urgency=low
+
+ * New upstream release
+ * debian/control
+ - Added python-oauthlib to python-requests' Recommends field
+ * debian/patches/01_do-not-use-python-certifi.patch
+ - Refreshed
+
+ -- Daniele Tricoli <eriol@mornie.org> Fri, 04 May 2012 14:34:47 +0200
+
requests (0.11.2-1) unstable; urgency=low
* New upstream release
diff --git a/debian/control b/debian/control
index cf877cc..d30000c 100644
--- a/debian/control
+++ b/debian/control
@@ -25,7 +25,8 @@ Depends:
python-six
Recommends:
python-chardet,
- python-gevent
+ python-gevent,
+ python-oauthlib
Description: elegant and simple HTTP library for Python, built for human beings
Requests allow you to send HTTP/1.1 requests. You can add headers, form data,
multipart files, and parameters with simple Python dictionaries, and access the
diff --git a/debian/patches/01_do-not-use-python-certifi.patch b/debian/patches/01_do-not-use-python-certifi.patch
index 5873743..74fb4d0 100644
--- a/debian/patches/01_do-not-use-python-certifi.patch
+++ b/debian/patches/01_do-not-use-python-certifi.patch
@@ -1,18 +1,17 @@
Description: To verify SSL certificates for HTTPS requests, use the bundle
- provided by ca-certificates instead of python-certifi. Since requests 0.11.2
- it is not needed to hard-code bundle path because requests will search for it.
+ provided by ca-certificates instead of python-certifi.
Author: Daniele Tricoli <eriol@mornie.org>
Forwarded: not-needed
-Last-Update: 2012-04-23
+Last-Update: 2012-05-04
--- a/setup.py
+++ b/setup.py
-@@ -21,7 +21,7 @@
- os.system('python tests/test_requests.py')
- sys.exit()
+@@ -32,7 +32,7 @@
+ # On certain supported platforms (e.g., Red Hat / Debian / FreeBSD), Requests can
+ # use the system CA bundle instead; see `requests.utils` for details.
+ # If your platform is supported, set `requires` to [] instead:
+-requires = ['certifi>=0.0.7']
++requires = []
--required = ['certifi>=0.0.7',]
-+required = []
- packages = [
- 'requests',
- 'requests.packages',
+ # chardet is used to optimally guess the encodings of pages that don't declare one.
+ # At this time, chardet is not a required dependency. However, it's sufficiently