aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c9d82a1..d547907 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,21 @@ export PYBUILD_NAME=requests
%:
dh $@ --with python2,python3 --buildsystem=pybuild
+# The test suite currently requires external network access, so we
+# can't enable it. Once this issue is fixed, it will be easy to
+# re-enable.
+#
+# https://github.com/kennethreitz/requests/issues/1166
+#
+# barry@debian.org 2014-06-04
+#override_dh_auto_test:
+# PYBUILD_SYSTEM=custom \
+# PYBUILD_TEST_ARGS="{interpreter} test_requests.py" \
+# http_proxy= https_proxy= \
+# dh_auto_test
+
+override_dh_auto_test:
+
override_dh_installchangelogs:
dh_installchangelogs HISTORY.rst