aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules30
1 files changed, 30 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e06fbba
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,30 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=requests
+
+%:
+ dh $@ --with python2,python3 --buildsystem=pybuild
+
+# The test suite currently requires external network access, so we
+# can't enable it. Once this issue is fixed, it will be easy to
+# re-enable.
+#
+# https://github.com/kennethreitz/requests/issues/2184
+#
+# barry@debian.org 2014-11-19
+#override_dh_auto_test:
+# PYBUILD_SYSTEM=custom \
+# PYBUILD_TEST_ARGS="{interpreter} test_requests.py" \
+# http_proxy= https_proxy= \
+# dh_auto_test
+
+override_dh_auto_test:
+
+override_dh_installchangelogs:
+ dh_installchangelogs HISTORY.rst
+
+override_dh_auto_install:
+ dh_auto_install
+ python3 setup.py bdist_wheel \
+ --universal \
+ -d $(CURDIR)/debian/tmp/usr/share/python-wheels