aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/01_use-system-ca-certificates.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/01_use-system-ca-certificates.patch')
-rw-r--r--debian/patches/01_use-system-ca-certificates.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/debian/patches/01_use-system-ca-certificates.patch b/debian/patches/01_use-system-ca-certificates.patch
new file mode 100644
index 0000000..f079c99
--- /dev/null
+++ b/debian/patches/01_use-system-ca-certificates.patch
@@ -0,0 +1,28 @@
+Description: Use the bundle provided by ca-certificates instead of
+ the embedded one.
+Author: Daniele Tricoli <eriol@mornie.org>
+Forwarded: not-needed
+Last-Update: 2013-01-19
+
+--- a/requests/certs.py 2013-04-25 22:54:02.000000000 +0000
++++ b/requests/certs.py 2013-04-25 22:54:34.000000000 +0000
+@@ -18,7 +18,7 @@
+ def where():
+ """Return the preferred certificate bundle."""
+ # vendored bundle inside Requests
+- return os.path.join(os.path.dirname(__file__), 'cacert.pem')
++ return '/etc/ssl/certs/ca-certificates.crt'
+
+ if __name__ == '__main__':
+ print(where())
+--- a/setup.py
++++ b/setup.py
+@@ -35,7 +35,7 @@
+ author_email='me@kennethreitz.com',
+ url='http://python-requests.org',
+ packages=packages,
+- package_data={'': ['LICENSE', 'NOTICE'], 'requests': ['*.pem']},
++ package_data={'': ['LICENSE', 'NOTICE'],},
+ package_dir={'requests': 'requests'},
+ include_package_data=True,
+ install_requires=requires,