diff options
author | SVN-Git Migration <python-modules-team@lists.alioth.debian.org> | 2015-10-08 13:41:21 -0700 |
---|---|---|
committer | SVN-Git Migration <python-modules-team@lists.alioth.debian.org> | 2015-10-08 13:41:21 -0700 |
commit | e75853fc04102c7f72f2e955b63f9692c472f64a (patch) | |
tree | 9847c33530102dcf8f42bba6a562a7df34d651e6 /setup.py | |
parent | 365ef510aa3581a79709673e078401724601fc71 (diff) | |
download | python-requests-e75853fc04102c7f72f2e955b63f9692c472f64a.tar python-requests-e75853fc04102c7f72f2e955b63f9692c472f64a.tar.gz |
Imported Upstream version 0.10.8
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 22 |
1 files changed, 12 insertions, 10 deletions
@@ -4,7 +4,7 @@ import os import sys import requests -from requests.compat import is_py3 +from requests.compat import is_py3, is_py2 try: from setuptools import setup @@ -22,11 +22,20 @@ if sys.argv[-1] == 'test': sys.exit() required = ['certifi>=0.0.7',] +packages = [ + 'requests', + 'requests.packages', + 'requests.packages.urllib3', + 'requests.packages.urllib3.packages', + 'requests.packages.urllib3.packages.ssl_match_hostname', + 'requests.packages.urllib3.packages.mimetools_choose_boundary', +] if is_py3: required.append('chardet2') else: required.append('chardet>=1.0.0') + packages.append('requests.packages.oreos') setup( @@ -38,15 +47,7 @@ setup( author='Kenneth Reitz', author_email='me@kennethreitz.com', url='http://python-requests.org', - packages=[ - 'requests', - 'requests.packages', - 'requests.packages.urllib3', - 'requests.packages.urllib3.packages', - 'requests.packages.urllib3.packages.ssl_match_hostname', - 'requests.packages.urllib3.packages.mimetools_choose_boundary', - 'requests.packages.oreos' - ], + packages=packages, package_data={'': ['LICENSE', 'NOTICE']}, include_package_data=True, install_requires=required, @@ -59,6 +60,7 @@ setup( 'Programming Language :: Python', 'Programming Language :: Python :: 2.6', 'Programming Language :: Python :: 2.7', + 'Programming Language :: Python :: 3', 'Programming Language :: Python :: 3.0', 'Programming Language :: Python :: 3.1', ), |