diff options
author | Jeremy T. Bouse <jbouse@debian.org> | 2014-05-11 22:30:26 -0400 |
---|---|---|
committer | Jeremy T. Bouse <jbouse@debian.org> | 2014-05-11 22:30:26 -0400 |
commit | 56d4b9be3ecb1f4dc6fd6c081d58286e323955b7 (patch) | |
tree | 4929cbf73c8bb4f4d896f67f23afdcd4463c784e /setup.py | |
parent | 5552efae3b0075cca67430a0be5b352f3a256475 (diff) | |
parent | 4e426087436d01fe00a120e5e7ce7a5e0a1e0970 (diff) | |
download | python-paramiko-56d4b9be3ecb1f4dc6fd6c081d58286e323955b7.tar python-paramiko-56d4b9be3ecb1f4dc6fd6c081d58286e323955b7.tar.gz |
Merge tag 'upstream/1.14.0'
Upstream version 1.14.0
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 53 |
1 files changed, 32 insertions, 21 deletions
@@ -40,9 +40,10 @@ import sys try: from setuptools import setup kw = { - 'install_requires': ['pycrypto >= 2.1, != 2.4', - 'ecdsa', - ], + 'install_requires': [ + 'pycrypto >= 2.1, != 2.4', + 'ecdsa', + ], } except ImportError: from distutils.core import setup @@ -53,21 +54,31 @@ if sys.platform == 'darwin': setup_helper.install_custom_make_tarball() -setup(name = "paramiko", - version = "1.12.2", - description = "SSH2 protocol library", - author = "Jeff Forcier", - author_email = "jeff@bitprophet.org", - url = "https://github.com/paramiko/paramiko/", - packages = [ 'paramiko' ], - license = 'LGPL', - platforms = 'Posix; MacOS X; Windows', - classifiers = [ 'Development Status :: 5 - Production/Stable', - 'Intended Audience :: Developers', - 'License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)', - 'Operating System :: OS Independent', - 'Topic :: Internet', - 'Topic :: Security :: Cryptography' ], - long_description = longdesc, - **kw - ) +setup( + name = "paramiko", + version = "1.14.0", + description = "SSH2 protocol library", + long_description = longdesc, + author = "Jeff Forcier", + author_email = "jeff@bitprophet.org", + url = "https://github.com/paramiko/paramiko/", + packages = [ 'paramiko' ], + license = 'LGPL', + platforms = 'Posix; MacOS X; Windows', + classifiers = [ + 'Development Status :: 5 - Production/Stable', + 'Intended Audience :: Developers', + 'License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)', + 'Operating System :: OS Independent', + 'Topic :: Internet', + 'Topic :: Security :: Cryptography', + 'Programming Language :: Python', + 'Programming Language :: Python :: 2', + 'Programming Language :: Python :: 2.6', + 'Programming Language :: Python :: 2.7', + 'Programming Language :: Python :: 3', + 'Programming Language :: Python :: 3.2', + 'Programming Language :: Python :: 3.3', + ], + **kw +) |