summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorChristopher Baines <chris@lucida.cbaines.net>2015-12-24 10:59:02 +0000
committerChristopher Baines <mail@cbaines.net>2015-12-30 13:09:00 +0000
commitb12129f0da219291e52b1725dae24528c882a55e (patch)
treecd37cd6b7f4a53eb7078dfdc1ff54639c9b45491 /debian/rules
downloadprometheus-pgbouncer-exporter-b12129f0da219291e52b1725dae24528c882a55e.tar
prometheus-pgbouncer-exporter-b12129f0da219291e52b1725dae24528c882a55e.tar.gz
Initial commit
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 12 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..b06eef5
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,12 @@
+#!/usr/bin/make -f
+
+export DH_VERBOSE=1
+
+%:
+ dh $@ --with=python3,systemd --buildsystem=pybuild
+
+override_dh_systemd_enable:
+ dh_systemd_enable prometheus-pgbouncer-exporter.service
+
+override_dh_systemd_start:
+ dh_systemd_start --restart-after-upgrade prometheus-pgbouncer-exporter.service