aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/control19
-rwxr-xr-xdebian/rules16
3 files changed, 35 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index d417477..d0e6609 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,8 +5,9 @@ pbuilder (0.159) UNRELEASED; urgency=low
dr@jones.dk (Closes: #385351).
* add notes in the comment that files in examples are useful for
--hookdir option.
+ * add patch from Mattia Dongili <malattia@linux.it> to revive pbuilder-uml.
- -- Junichi Uekawa <dancer@debian.org> Sun, 3 Sep 2006 18:12:21 +0900
+ -- Junichi Uekawa <dancer@debian.org> Sat, 16 Sep 2006 16:59:02 +0900
pbuilder (0.158) unstable; urgency=low
diff --git a/debian/control b/debian/control
index f17c2dc..05e5270 100644
--- a/debian/control
+++ b/debian/control
@@ -29,3 +29,22 @@ Description: personal package builder for Debian packages
.
pdebuild is a wrapper for Debian Developers, to allow running
pbuilder just like "debuild", as a normal user.
+
+Package: pbuilder-uml
+Architecture: i386
+Depends: rootstrap (>= 0.3.9-1), user-mode-linux, pbuilder (= ${Source-Version})
+Description: user-mode-linux version of pbuilder
+ pbuilder-uml uses a User-mode-linux system, and builds Debian packages
+ inside the UML image. It is an ideal system to use to check
+ that a package has correct build-dependencies.
+ It uses apt extensively, and a local mirror, or a fast connection
+ to a Debian mirror is ideal, but not necessary.
+ .
+ Requires user-mode-linux to function correctly
+ .
+ "pbuilder-user-mode-linux create" uses rootstrap to create UML image
+ .
+ "pbuilder-user-mode-linux update" updates the image to the current state of
+ testing/unstable/whatever
+ .
+ "pbuilder-user-mode-linux build" takes a *.dsc file and builds a binary in the UML
diff --git a/debian/rules b/debian/rules
index 64323c5..7c032ab 100755
--- a/debian/rules
+++ b/debian/rules
@@ -30,7 +30,6 @@ clean:
# Add here commands to clean up after the build process.
-$(MAKE) clean
- rm -rf debian/pbuilder-uml/
dh_clean
install: build
@@ -61,7 +60,20 @@ binary-indep: build install
# Build architecture-dependent files here.
binary-arch: build install
- echo NOTE: pbuilder-uml is not built see changelog for version 0.117
+ifeq (${ARCH},i386)
+ dh_testdir -a
+ dh_testroot -a
+ dh_installdocs -a
+ dh_installman -ppbuilder-uml pbuilder-user-mode-linux.1 pbuilder-uml.conf.5 pdebuild-user-mode-linux.1
+ dh_installchangelogs -a
+ dh_link -a
+ dh_compress -a
+ dh_fixperms -a
+ dh_installdeb -a
+ dh_gencontrol -a
+ dh_md5sums -a
+ dh_builddeb -a
+endif
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure