aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-07-19 14:16:21 +0200
committerJoey Hess <joey@gnu.kitenet.net>2009-07-19 14:16:21 +0200
commitae4837bb3d3dcc5cea233b0c1ac9f01384d2590d (patch)
treeaaca0100526d47355787f192882ad612840d5e1c /Makefile.PL
parent4d166acccbd9c46b92bbda93a5e0876d4619afab (diff)
downloadikiwiki-ae4837bb3d3dcc5cea233b0c1ac9f01384d2590d.tar
ikiwiki-ae4837bb3d3dcc5cea233b0c1ac9f01384d2590d.tar.gz
add basewikipo po file generation thing
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL20
1 files changed, 19 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 93f9e89e2..848cad87c 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -36,7 +36,7 @@ ikiwiki.out: ikiwiki.in
ikiwiki.setup: ikiwiki.out
HOME=/home/me $(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.out -libdir . -dumpsetup ikiwiki.setup
-extra_build: ikiwiki.out ikiwiki.setup docwiki
+extra_build: ikiwiki.out ikiwiki.setup docwiki basewikipo
./mdwn2man ikiwiki 1 doc/usage.mdwn > ikiwiki.man
./mdwn2man ikiwiki-mass-rebuild 8 doc/ikiwiki-mass-rebuild.mdwn > ikiwiki-mass-rebuild.man
./mdwn2man ikiwiki-makerepo 1 doc/ikiwiki-makerepo.mdwn > ikiwiki-makerepo.man
@@ -47,6 +47,24 @@ extra_build: ikiwiki.out ikiwiki.setup docwiki
docwiki: ikiwiki.out
$(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.out -libdir . -setup docwiki.setup -refresh
+basewikipo: ikiwiki.out
+ # copy all the files we want to translate into the
+ # po/underlays scrdir.
+ for file in `find underlays -follow -name \*.mdwn`; do \
+ install -d po/$$(dirname $$file); \
+ cp -aL $$file po/$$file 2>/dev/null || \
+ install -m 644 $$file po/$$file; \
+ done
+ install -d po/underlays/directives/ikiwiki/directive
+ for file in doc/ikiwiki/directive/*; do \
+ if [ -f "$$file" ]; then \
+ install -m 644 $$file po/underlays/directives/ikiwiki/directive; \
+ fi \
+ done
+ $(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.out -libdir . -setup basewikipo.setup -refresh
+ rm -rf po/html po/underlays/.ikiwiki
+ find po/underlays -name \*.mdwn | xargs rm -f
+
extra_clean:
rm -rf html doc/.ikiwiki
rm -f *.man ikiwiki.out ikiwiki.setup plugins/*.pyc