aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-07-20 07:20:13 +0200
committerJoey Hess <joey@gnu.kitenet.net>2009-07-20 07:20:13 +0200
commita7b813182df7d18a0d1bf2fb28b3ee4c069c86e9 (patch)
tree83b7d4840e91e1c3cf2d72b47c01bde4f701d0d2 /Makefile.PL
parente04692e059c41e5616ead2f198ed498ec3a2f290 (diff)
downloadikiwiki-a7b813182df7d18a0d1bf2fb28b3ee4c069c86e9.tar
ikiwiki-a7b813182df7d18a0d1bf2fb28b3ee4c069c86e9.tar.gz
build translated underlays for use with non-English wikis
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL21
1 files changed, 0 insertions, 21 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 397627c03..93f9e89e2 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -47,31 +47,10 @@ extra_build: ikiwiki.out ikiwiki.setup docwiki
docwiki: ikiwiki.out
$(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.out -libdir . -setup docwiki.setup -refresh
-underlaypo: ikiwiki.out
- # copy all the files we want to translate into the
- # po/underlays scrdir.
- for file in `find underlays -follow -name \*.mdwn`; do \
- install -d po/$$(dirname $$file); \
- cp -aL $$file po/$$file 2>/dev/null || \
- install -m 644 $$file po/$$file; \
- done
- install -d po/underlays/directives/ikiwiki/directive
- for file in doc/ikiwiki/directive/*; do \
- if [ -f "$$file" ]; then \
- cp -a $$file po/underlays/directives/ikiwiki/directive || \
- install -m 644 $$file po/underlays/directives/ikiwiki/directive; \
- fi \
- done
- install -d po/underlays/empty
- $(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.out -libdir . -setup underlaypo.setup -refresh
- PERL5LIB=. po/po2wiki underlaypo.setup
- find po/underlays -name \*.mdwn | xargs rm -f
-
extra_clean:
rm -rf html doc/.ikiwiki
rm -f *.man ikiwiki.out ikiwiki.setup plugins/*.pyc
$(MAKE) -C po clean
- rm -rf po/html po/underlays/.ikiwiki
extra_install:
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki