aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorJoey Hess <joey@gnu.kitenet.net>2009-11-09 13:47:37 -0500
committerJoey Hess <joey@gnu.kitenet.net>2009-11-09 13:47:37 -0500
commit76d72e9bdd983ca05d84bef158644ff009931e31 (patch)
tree5d9af4e1784cf26ac24e726581c0ce3a38d0e304 /Makefile.PL
parent9f0931ce21e5f58e2e9de0ef302beca08b8f9177 (diff)
downloadikiwiki-76d72e9bdd983ca05d84bef158644ff009931e31.tar
ikiwiki-76d72e9bdd983ca05d84bef158644ff009931e31.tar.gz
more portable use of sed -i
Apparently OS X requires the extension be specified. But this turns on backup in GNU sed, so have to remove that.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 474098814..462f7364d 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -44,7 +44,8 @@ extra_build: ikiwiki.out ikiwiki.setup docwiki
./mdwn2man ikiwiki-update-wikilist 1 doc/ikiwiki-update-wikilist.mdwn > ikiwiki-update-wikilist.man
./mdwn2man ikiwiki-calendar 1 doc/ikiwiki-calendar.mdwn > ikiwiki-calendar.man
$(MAKE) -C po
- sed -i "s/Version:.*/Version: $$(perl -e '$$_=<>;print m/\((.*?)\)/'<debian/changelog)/" ikiwiki.spec
+ sed -i.bkp "s/Version:.*/Version: $$(perl -e '$$_=<>;print m/\((.*?)\)/'<debian/changelog)/" ikiwiki.spec
+ rm -f ikiwiki.spec.bkp
docwiki: ikiwiki.out
$(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.out -libdir . -setup docwiki.setup -refresh