aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2011-08-24 16:25:03 -0400
committerJoey Hess <joey@kitenet.net>2011-08-24 16:25:03 -0400
commit73eb892ba2639447ef6fbd5157c719a7bc0e65a4 (patch)
tree5070438ae30152bf006ed06a336dcbb66faf2b90 /Makefile.PL
parente92f292525c615daf98c3bcf6a10a252bc77ebaa (diff)
downloadikiwiki-73eb892ba2639447ef6fbd5157c719a7bc0e65a4.tar
ikiwiki-73eb892ba2639447ef6fbd5157c719a7bc0e65a4.tar.gz
jquery source cleanup
* Add unminified jquery js and css files to source. * Update to jquery 1.6.2, and jquery-ui 1.8.14. The full files are included in the source but not the binary. I'm not minifying the files as part of build because I don't want ikiwiki to build depend on a javascript minifier. (Let alone need one at runtime). Nor do I want to deal with any breakage caused by the minifier. These files were taken from the debian packages. The jquery-tmpl full file was taken from revision 66bb852217c49ae8c9a8f2522150354ae80463de of its git repository, which matches the minified file I already had. I did not want to deal with possible breakage in newer versions; this thing claims to need an ancient version of jquery (1.4.2), and is perhaps only working by luck with the newer versions as it is.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index c3df9759b..e1a953f8f 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -69,7 +69,7 @@ underlay_install:
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki
for dir in `cd underlays && $(FIND) . -follow -type d`; do \
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
- for file in `$(FIND) underlays/$$dir -follow -maxdepth 1 -type f`; do \
+ for file in `$(FIND) underlays/$$dir -follow -maxdepth 1 -type f -not -name \\*.full.js -not -name \\*.full.css`; do \
cp -aL $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir 2>/dev/null || \
install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
done; \