aboutsummaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorAmitai Schlair <schmonz-web-ikiwiki@schmonz.com>2014-09-19 00:53:16 -0400
committerAmitai Schlair <schmonz-web-ikiwiki@schmonz.com>2014-09-19 00:53:16 -0400
commit053de5489bb2a00855f46b131fe676cc3bc94579 (patch)
tree8efd23158dca35bb09bf1196795fb2098ba79b2e /Makefile.PL
parent5918ce000e0221d776ce71ba4f83bf5577a45447 (diff)
downloadikiwiki-053de5489bb2a00855f46b131fe676cc3bc94579.tar
ikiwiki-053de5489bb2a00855f46b131fe676cc3bc94579.tar.gz
Anchor subst to opening ", avoiding side effects.
SYSCONFDIR might be overridden to a value containing "etc/ikiwiki", in which case we might overzealously substitute more than once, especially if SYSCONFDIR is overridden to different values at build and install time. Avoid this by matching only the instances we meant to match.
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index ad3e4623c..13ed103c7 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -60,7 +60,7 @@ docwiki:
$(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.in -setup docwiki.setup -refresh
sysconfdir:
- $(PERL) -pi -e "s|/etc/ikiwiki|$(SYSCONFDIR)|g" $(sysconfdir_scripts)
+ $(PERL) -pi -e "s|\"/etc/ikiwiki|\"$(SYSCONFDIR)|g" $(sysconfdir_scripts)
extra_clean:
$(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.in -setup docwiki.setup -clean