From bb251307642242bb9174e9c4d89909ca40926d67 Mon Sep 17 00:00:00 2001
From: Ludovic Courtès <ludo@gnu.org>
Date: Tue, 12 Jan 2016 16:37:45 +0100
Subject: build: 'make check' errors out if file name limits would be hit.

* Makefile.am (SCM_TESTS, SH_TESTS, TESTS, AM_TESTS_ENVIRONMENT)
(SCM_LOG_COMPILER, SH_LOG_COMPILER, AM_SCM_LOG_FLAGS)
(AM_SH_LOG_FLAGS): Move within 'if CAN_RUN_TESTS'.
(check-local) [!CAN_RUN_TESTS]: New target.
* daemon.am (AM_TESTS_ENVIRONMENT, TESTS): Ditto.
* m4/guix.m4 (GUIX_CHECK_FILE_NAME_LIMITS): Add parameter and set it.
---
 m4/guix.m4 | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

(limited to 'm4')

diff --git a/m4/guix.m4 b/m4/guix.m4
index 96319b2c14..563ce51699 100644
--- a/m4/guix.m4
+++ b/m4/guix.m4
@@ -215,7 +215,8 @@ AC_DEFUN([GUIX_TEST_HASH_BANG_LENGTH], [
 dnl GUIX_CHECK_FILE_NAME_LIMITS
 dnl
 dnl GNU/Linux has a couple of silly limits that we can easily run into.
-dnl Make sure everything is fine with the current settings.
+dnl Make sure everything is fine with the current settings.  Set $1 to
+dnl 'yes' if tests can run, 'no' otherwise.
 AC_DEFUN([GUIX_CHECK_FILE_NAME_LIMITS], [
   AC_REQUIRE([GUIX_SOCKET_FILE_NAME_LENGTH])
   AC_REQUIRE([GUIX_TEST_SOCKET_FILE_NAME_LENGTH])
@@ -228,10 +229,14 @@ AC_DEFUN([GUIX_CHECK_FILE_NAME_LIMITS], [
   if test "$ac_cv_guix_test_socket_file_name_length" -ge ]SOCKET_FILE_NAME_LIMIT[; then
     AC_MSG_WARN([socket file name limit may be exceeded when running tests])
   fi
+
+  $1=yes
   if test "$ac_cv_guix_hash_bang_length" -ge ]LINUX_HASH_BANG_LIMIT[; then
+    $1=no
     AC_MSG_ERROR([store directory '$storedir' would lead to overly long hash-bang lines])
   fi
   if test "$ac_cv_guix_test_hash_bang_length" -ge ]LINUX_HASH_BANG_LIMIT[; then
+    $1=no
     AC_MSG_WARN([test directory '$ac_cv_guix_test_root' may lead to overly long hash-bang lines])
   fi
 ])
-- 
cgit v1.2.3