From 8df39f572cf5f2bdf1181aa23b5ace17615b0323 Mon Sep 17 00:00:00 2001
From: Petter <petter@mykolab.ch>
Date: Tue, 24 Oct 2017 23:06:27 +0200
Subject: gnu: Add perl-moox-file-configdir.

* gnu/packages/perl.scm (perl-moox-file-configdir): New variable.

Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
---
 gnu/packages/perl.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

(limited to 'gnu')

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index b9123513ef..992c21de43 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5517,6 +5517,30 @@ the path through the tree (starting from the top-level command through to the
 most specific one) is instantiated.")
     (license (package-license perl))))
 
+(define-public perl-moox-file-configdir
+  (package
+    (name "perl-moox-file-configdir")
+    (version "0.006")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/R/RE/RESHACK/"
+                           "MooX-File-ConfigDir-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0f808sq3627ymgf63zwgh705vv0nhwclxp89clhx8yl6hybcv7kx"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-file-configdir" ,perl-file-configdir)
+       ("perl-moo" ,perl-moo)
+       ("perl-namespace-clean" ,perl-namespace-clean)))
+    (home-page "http://search.cpan.org/dist/MooX-File-ConfigDir/")
+    (synopsis "Moo eXtension for @code{File::ConfigDir}")
+    (description "This module is a helper for easily finding configuration
+file locations.  This information can be used to find a suitable place for
+installing configuration files or for finding any piece of settings.")
+    (license (package-license perl))))
+
 (define-public perl-moox-handlesvia
   (package
     (name "perl-moox-handlesvia")
-- 
cgit v1.2.3