From fa68a9bbe97c89cf67b27c8767c709301e2b433d Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Mon, 11 Jul 2016 19:04:49 +0300
Subject: gnu: ghostscript: Add `gs' binary.

This is a followup to commit eb354bdacbf4154ec66038dac07f19bf4ced1fad.

* gnu/packages/ghostscript.scm (ghostscript)[arguments]: Create a
symlink from `gsc' to `gs' to provide a `gs' binary.
---
 gnu/packages/ghostscript.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

(limited to 'gnu/packages')

diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index f013a734e5..714544c2e6 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -182,7 +182,12 @@ printing, and psresize, for adjusting page sizes.")
                             (number->string (parallel-job-count))))))
         (replace 'install
           (lambda _
-            (zero? (system* "make" "soinstall")))))))
+            (zero? (system* "make" "soinstall"))))
+        (add-after 'install 'create-gs-symlink
+          (lambda* (#:key outputs #:allow-other-keys)
+            (let ((out (assoc-ref outputs "out")))
+              ;; some programs depend on having a 'gs' binary available
+              (symlink "gsc" (string-append out "/bin/gs"))))))))
    (synopsis "PostScript and PDF interpreter")
    (description
     "Ghostscript is an interpreter for the PostScript language and the PDF
-- 
cgit v1.2.3