From d8f46d52343972af6734c28cce94559e1c78481f Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Fri, 9 Mar 2018 11:20:22 +0100
Subject: gnu: hdf5: Do not record the build-time kernel version.

* gnu/packages/maths.scm (hdf5)[arguments]: Patch libhdf5.settings to prevent
the kernel version on the build node from affecting the output.
---
 gnu/packages/maths.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

(limited to 'gnu/packages')

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 8d0c10697f..cf3d8ae836 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -724,7 +724,11 @@ incompatible with HDF5.")
              ;; unnecessary store references to those compilers:
              (substitute* "src/libhdf5.settings"
               (("(/gnu/store/)([a-Z0-9]*)" all prefix hash)
-               (string-append prefix (string-take hash 10) "...")))
+               (string-append prefix (string-take hash 10) "..."))
+              ;; Don't record the build-time kernel version to make the
+              ;; settings file reproducible.
+              (("Uname information:.*")
+               "Uname information: Linux\n"))
              #t))
          (add-after 'install 'patch-references
            (lambda* (#:key inputs outputs #:allow-other-keys)
-- 
cgit v1.2.3