From a3a5b01240174b0d5e12b41dd1187c106d88de6d Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Wed, 11 Oct 2017 00:48:55 -0400
Subject: gnu: Add go-github-com-edsrzf-mmap-go.

* gnu/packages/syncthing.scm (go-github-com-edsrzf-mmap-go): New variable.
---
 gnu/packages/syncthing.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

(limited to 'gnu/packages')

diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 4d1b2a86fe..a98502ce5a 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -141,3 +141,26 @@ reflection.")
 structs in the Go programming language.")
       (home-page "https://github.com/d4l3k/messagediff")
       (license expat))))
+
+(define-public go-github-com-edsrzf-mmap-go
+  (let ((commit "0bce6a6887123b67a60366d2c9fe2dfb74289d2e")
+        (revision "0"))
+    (package
+      (name "go-github-com-edsrzf-mmap-go")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/edsrzf/mmap-go")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1am4m2k451bksnbiqj6lxknk4lsgmrhv0q3ajqac818vj0cpfgs9"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/edsrzf/mmap-go"))
+      (synopsis "Go implementation of mmap")
+      (description "This packages provides a Go implementation of mmap.")
+      (home-page "https://github.com/edsrzf/mmap-go")
+      (license bsd-3))))
-- 
cgit v1.2.3