From 5568151f5b571346e8c1760a1e0be9d7fd01b665 Mon Sep 17 00:00:00 2001
From: Ludovic Courtès <ludo@gnu.org>
Date: Sun, 13 Dec 2015 15:14:06 +0100
Subject: gnu: wireless-regdb: Build sequentially.

Fixes <http://bugs.gnu.org/22126>.
Reported by Mark H Weaver <mhw@netris.org>.

* gnu/packages/linux.scm (wireless-regdb)[source]: Add 'snippet'.
[arguments]: Add #:parallel-build?.
---
 gnu/packages/linux.scm | 12 +++++++++++-
 1 file changed, 11 insertions(+), 1 deletion(-)

(limited to 'gnu/packages')

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 503f9c3368..ad3bd51554 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1759,11 +1759,21 @@ compliance.")
                     "wireless-regdb-" version ".tar.xz"))
               (sha256
                (base32
-                "0czi83k311fp27z42hxjm8vi88fsbc23mhavv96lkb4pmari0jjc"))))
+                "0czi83k311fp27z42hxjm8vi88fsbc23mhavv96lkb4pmari0jjc"))
+
+              ;; We're building 'regulatory.bin' by ourselves.
+              (snippet '(delete-file "regulatory.bin"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
                   (delete 'configure))
+
+       ;; The 'all' target of the makefile depends on $(REGDB_CHANGED), which
+       ;; is computed and can be equal to 'maintainer-clean'; when that
+       ;; happens, we can end up deleting the 'regulatory.bin' file that we
+       ;; just built.  Thus, build things sequentially.
+       #:parallel-build? #f
+
        #:tests? #f                                ;no tests
        #:make-flags (let ((out (assoc-ref %outputs "out")))
                       (list (string-append "PREFIX=" out)
-- 
cgit v1.2.3