From 178bd68116a0720c5b990fea1af770630844f297 Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <ricardo.wurmus@mdc-berlin.de>
Date: Wed, 15 Aug 2018 11:46:49 +0200
Subject: gnu: ghc-vector-algorithms: Fix build errors.

* gnu/packages/haskell.scm (ghc-vector-algorithms)[arguments]:
Allow build with newer version of vector; add phase to disable building of
broken QuickCheck tests.
---
 gnu/packages/haskell.scm | 11 +++++++++++
 1 file changed, 11 insertions(+)

(limited to 'gnu/packages')

diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 5efce7388d..577ecb8a0e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8307,6 +8307,17 @@ between 2 and 3 times faster than the Mersenne Twister.")
         (base32
          "0w4hf598lpxfg58rnimcqxrbnpqq2jmpjx82qa5md3q6r90hlipd"))))
     (build-system haskell-build-system)
+    ;; The limits have been adjusted in a revision of the cabal file.
+    (arguments
+     '(#:configure-flags (list "--allow-newer=vector")
+       #:phases
+       (modify-phases %standard-phases
+         ;; The tests cannot be built due to type errors.
+         (add-after 'unpack 'do-not-build-quickcheck-tests
+           (lambda _
+             (substitute* "vector-algorithms.cabal"
+               (("\\!flag\\(properties\\)") "True"))
+             #t)))))
     (inputs
      `(("ghc-vector" ,ghc-vector)
        ("ghc-mtl" ,ghc-mtl)
-- 
cgit v1.2.3