From d9465101f4f3d764e89f6c819a19428980a6106a Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sun, 31 Dec 2017 22:25:36 +0000
Subject: gnu: libksysguard: Update to 5.11.4.

* gnu/packages/kde.scm (libksysguard): Update to 5.11.4.
---
 gnu/packages/kde.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

(limited to 'gnu/packages/kde.scm')

diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 89ad30ecd2..94834c336c 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
 ;;; Copyright © 2017 Mark Meyer <mark@ofosos.org>
+;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -349,7 +350,7 @@ used in KDE development tools Kompare and KDevelop.")
 (define-public libksysguard
   (package
     (name "libksysguard")
-    (version "5.11.2")
+    (version "5.11.4")
     (source
      (origin
        (method url-fetch)
@@ -357,7 +358,7 @@ used in KDE development tools Kompare and KDevelop.")
                            "/libksysguard-" version ".tar.xz"))
        (sha256
         (base32
-         "12d0r4rilydbqdgkm256khvkb9m0hya3p27xqvv3hg77wgxzdl3f"))))
+         "1ry4478fv7blp80zyhz0xr3qragsddrkzjzmxkdarh01f4p987aq"))))
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)
        ("pkg-config" ,pkg-config)))
@@ -399,7 +400,7 @@ used in KDE development tools Kompare and KDevelop.")
            (lambda _
              ;; TODO: Fix this failing test-case
              (zero? (system* "ctest" "-E" "processtest")))))))
-    (home-page "https://www.kde.org/info/plasma-5.11.2.php")
+    (home-page "https://www.kde.org/info/plasma-5.11.4.php")
     (synopsis "Network enabled task and system monitoring")
     (description "KSysGuard can obtain information on system load and
 manage running processes.  It obtains this information by interacting
-- 
cgit v1.2.3


From 990e93fce16a83e1603b9ec28123ec3edc7ea787 Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Sun, 31 Dec 2017 13:15:31 -0500
Subject: gnu: krita: Ensure icons are found at runtime.

Fixes <https://bugs.gnu.org/29905>.

* gnu/packages/kde.scm (krita)[arguments]: Set the QT_PLUGIN_PATH in a
new 'wrap-executable' phase.
---
 gnu/packages/kde.scm | 16 +++++++++++++++-
 1 file changed, 15 insertions(+), 1 deletion(-)

(limited to 'gnu/packages/kde.scm')

diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 94834c336c..fdfca94e21 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -260,7 +260,21 @@ plugins, as well as code to create plugins, or complete applications.")
                             (assoc-ref %build-inputs "libtiff"))
              (string-append "-DCMAKE_CXX_FLAGS=-I"
                             (assoc-ref %build-inputs "ilmbase")
-                            "/include/OpenEXR"))))
+                            "/include/OpenEXR"))
+       #:phases
+       (modify-phases %standard-phases
+         ;; Ensure that icons are found at runtime
+         (add-after 'install 'wrap-executable
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out"))
+                   (qt '("qtbase" "qtsvg")))
+               (wrap-program (string-append out "/bin/krita")
+                 `("QT_PLUGIN_PATH" ":" prefix
+                   ,(map (lambda (label)
+                           (string-append (assoc-ref inputs label)
+                                          "/lib/qt5/plugins/"))
+                         qt)))
+               #t))))))
     (native-inputs
      `(("curl" ,curl)
        ("eigen" ,eigen)
-- 
cgit v1.2.3


From 1ee750ba4c76d9eff248b0f0657e0d8f119607ff Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Wed, 3 Jan 2018 12:33:07 -0500
Subject: gnu: krita: Add comment about the wrapper.

* gnu/packages/kde.scm (krita): Add comment.
---
 gnu/packages/kde.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

(limited to 'gnu/packages/kde.scm')

diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index fdfca94e21..f0df44528e 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -263,7 +263,8 @@ plugins, as well as code to create plugins, or complete applications.")
                             "/include/OpenEXR"))
        #:phases
        (modify-phases %standard-phases
-         ;; Ensure that icons are found at runtime
+         ;; Ensure that icons are found at runtime.
+         ;; This works around <https://bugs.gnu.org/22138>.
          (add-after 'install 'wrap-executable
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))
-- 
cgit v1.2.3