From eb31d4b4f12d82b3cd8ab04c0e8a796322e6abbc Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Tue, 24 Nov 2015 13:18:06 +0200
Subject: gnu: python-pyjwt: Update to 1.4.0.

* gnu/packages/python.scm (python-pyjwt): Update to 1.4.0.
[native-inputs]: Move python-setuptools here, add python-pytest-runner.
---
 gnu/packages/python.scm | 13 ++++++-------
 1 file changed, 6 insertions(+), 7 deletions(-)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index bab64612b0..6d1a8e0d0f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2159,19 +2159,18 @@ somewhat intelligeble.")
 (define-public python-pyjwt
   (package
     (name "python-pyjwt")
-    (version "0.2.1")
+    (version "1.4.0")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append
-             "https://pypi.python.org/packages/source/P/PyJWT/PyJWT-"
-             version ".tar.gz"))
+       (uri (pypi-uri "PyJWT" version))
        (sha256
         (base32
-         "1ahqblfy2sj3xz34wsa48cn9rp0dspzq56p54i5znmws3b8gml6g"))))
+         "1556v2jppd8mjkkj66pxb5rcazm35jq81r233mdl8hfmz9n3icp1"))))
     (build-system python-build-system)
-    (inputs
-     `(("python-setuptools" ,python-setuptools)))
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)
+       ("python-pytest-runner" ,python-pytest-runner)))
     (arguments
      '(#:tests? #f)) ; test suite doesn't work
     (home-page "http://github.com/progrium/pyjwt")
-- 
cgit v1.2.3