summaryrefslogtreecommitdiff
path: root/nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix')
-rw-r--r--nix/libstore/build.cc36
-rw-r--r--nix/libstore/builtins.cc69
-rw-r--r--nix/libstore/builtins.hh41
-rw-r--r--nix/local.mk5
-rw-r--r--nix/scripts/download.in11
5 files changed, 154 insertions, 8 deletions
diff --git a/nix/libstore/build.cc b/nix/libstore/build.cc
index ae78e65199..889ee3d2bd 100644
--- a/nix/libstore/build.cc
+++ b/nix/libstore/build.cc
@@ -8,6 +8,7 @@
#include "util.hh"
#include "archive.hh"
#include "affinity.hh"
+#include "builtins.hh"
#include <map>
#include <sstream>
@@ -2047,7 +2048,12 @@ void DerivationGoal::runChild()
commonChildInit(builderOut);
#if CHROOT_ENABLED
- if (useChroot) {
+ /* Note: built-in builders are *not* running in a chroot environment
+ so that we can easily implement them in Guile without having it as
+ a derivation input (they are running under a separate build user,
+ though). */
+
+ if (useChroot && !isBuiltin(drv)) {
/* Initialise the loopback interface. */
AutoCloseFD fd(socket(PF_INET, SOCK_DGRAM, IPPROTO_IP));
if (fd == -1) throw SysError("cannot open IP socket");
@@ -2255,6 +2261,28 @@ void DerivationGoal::runChild()
throw SysError("setuid failed");
}
+ restoreSIGPIPE();
+
+ /* Indicate that we managed to set up the build environment. */
+ writeFull(STDERR_FILENO, "\n");
+
+ /* Execute the program. This should not return. */
+ if (isBuiltin(drv)) {
+ try {
+ logType = ltFlat;
+
+ auto buildDrv = lookupBuiltinBuilder(drv.builder);
+ if (buildDrv != NULL)
+ buildDrv(drv, drvPath);
+ else
+ throw Error(format("unsupported builtin function '%1%'") % string(drv.builder, 8));
+ _exit(0);
+ } catch (std::exception & e) {
+ writeFull(STDERR_FILENO, "error: " + string(e.what()) + "\n");
+ _exit(1);
+ }
+ }
+
/* Fill in the arguments. */
Strings args;
string builderBasename = baseNameOf(drv.builder);
@@ -2262,12 +2290,6 @@ void DerivationGoal::runChild()
foreach (Strings::iterator, i, drv.args)
args.push_back(rewriteHashes(*i, rewritesToTmp));
- restoreSIGPIPE();
-
- /* Indicate that we managed to set up the build environment. */
- writeFull(STDERR_FILENO, "\n");
-
- /* Execute the program. This should not return. */
execve(drv.builder.c_str(), stringsToCharPtrs(args).data(), stringsToCharPtrs(envStrs).data());
throw SysError(format("executing `%1%'") % drv.builder);
diff --git a/nix/libstore/builtins.cc b/nix/libstore/builtins.cc
new file mode 100644
index 0000000000..605e44079a
--- /dev/null
+++ b/nix/libstore/builtins.cc
@@ -0,0 +1,69 @@
+/* GNU Guix --- Functional package management for GNU
+ Copyright (C) 2016 Ludovic Courtès <ludo@gnu.org>
+
+ This file is part of GNU Guix.
+
+ GNU Guix is free software; you can redistribute it and/or modify it
+ under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or (at
+ your option) any later version.
+
+ GNU Guix is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with GNU Guix. If not, see <http://www.gnu.org/licenses/>. */
+
+#include <builtins.hh>
+#include <util.hh>
+#include <globals.hh>
+
+#include <unistd.h>
+
+namespace nix {
+
+static void builtinDownload(const Derivation &drv,
+ const std::string &drvPath)
+{
+ /* Invoke 'guix perform-download'. */
+ Strings args;
+ args.push_back("perform-download");
+ args.push_back(drvPath);
+
+ /* Close all other file descriptors. */
+ closeMostFDs(set<int>());
+
+ const char *const argv[] = { "download", drvPath.c_str(), NULL };
+
+ /* XXX: Hack our way to use the 'download' script from 'LIBEXECDIR/guix'
+ or just 'LIBEXECDIR', depending on whether we're running uninstalled or
+ not. */
+ const string subdir = getenv("GUIX_UNINSTALLED") != NULL
+ ? "" : "/guix";
+
+ const string program = settings.nixLibexecDir + subdir + "/download";
+ execv(program.c_str(), (char *const *) argv);
+
+ throw SysError(format("failed to run download program '%1%'") % program);
+}
+
+static const std::map<std::string, derivationBuilder> builtins =
+{
+ { "download", builtinDownload }
+};
+
+derivationBuilder lookupBuiltinBuilder(const std::string & name)
+{
+ if (name.substr(0, 8) == "builtin:")
+ {
+ auto realName = name.substr(8);
+ auto builder = builtins.find(realName);
+ return builder == builtins.end() ? NULL : builder->second;
+ }
+ else
+ return NULL;
+}
+
+}
diff --git a/nix/libstore/builtins.hh b/nix/libstore/builtins.hh
new file mode 100644
index 0000000000..0c6db651ab
--- /dev/null
+++ b/nix/libstore/builtins.hh
@@ -0,0 +1,41 @@
+/* GNU Guix --- Functional package management for GNU
+ Copyright (C) 2016 Ludovic Courtès <ludo@gnu.org>
+
+ This file is part of GNU Guix.
+
+ GNU Guix is free software; you can redistribute it and/or modify it
+ under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or (at
+ your option) any later version.
+
+ GNU Guix is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with GNU Guix. If not, see <http://www.gnu.org/licenses/>. */
+
+/* Interface to built-in derivation builders. */
+
+#pragma once
+
+#include <derivations.hh>
+#include <map>
+#include <string>
+
+namespace nix {
+
+ inline bool isBuiltin(const Derivation & drv)
+ {
+ return string(drv.builder, 0, 8) == "builtin:";
+ }
+
+ /* Build DRV, which lives at DRVPATH. */
+ typedef void (*derivationBuilder) (const Derivation &drv,
+ const std::string &drvPath);
+
+ /* Return the built-in builder called BUILDER, or NULL if none was
+ found. */
+ derivationBuilder lookupBuiltinBuilder(const std::string &builder);
+}
diff --git a/nix/local.mk b/nix/local.mk
index c666edd033..86ef769549 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -87,6 +87,7 @@ libstore_a_SOURCES = \
%D%/libstore/build.cc \
%D%/libstore/pathlocks.cc \
%D%/libstore/derivations.cc \
+ %D%/libstore/builtins.cc \
%D%/libstore/sqlite.cc
libstore_headers = \
@@ -98,6 +99,7 @@ libstore_headers = \
%D%/libstore/misc.hh \
%D%/libstore/local-store.hh \
%D%/libstore/sqlite.hh \
+ %D%/libstore/builtins.hh \
%D%/libstore/store-api.hh
libstore_a_CPPFLAGS = \
@@ -166,7 +168,8 @@ noinst_HEADERS = \
nodist_pkglibexec_SCRIPTS = \
%D%/scripts/list-runtime-roots \
- %D%/scripts/substitute
+ %D%/scripts/substitute \
+ %D%/scripts/download
if BUILD_DAEMON_OFFLOAD
diff --git a/nix/scripts/download.in b/nix/scripts/download.in
new file mode 100644
index 0000000000..4d7088a993
--- /dev/null
+++ b/nix/scripts/download.in
@@ -0,0 +1,11 @@
+#!@SHELL@
+# A shorthand for "guix perform-download", for use by the daemon.
+
+if test "x$GUIX_UNINSTALLED" = "x"
+then
+ prefix="@prefix@"
+ exec_prefix="@exec_prefix@"
+ exec "@bindir@/guix" perform-download "$@"
+else
+ exec guix perform-download "$@"
+fi