summaryrefslogtreecommitdiff
path: root/nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix')
-rw-r--r--nix/libstore/globals.cc1
-rw-r--r--nix/libstore/globals.hh2
-rw-r--r--nix/local.mk3
3 files changed, 1 insertions, 5 deletions
diff --git a/nix/libstore/globals.cc b/nix/libstore/globals.cc
index ac92971887..130b0937fd 100644
--- a/nix/libstore/globals.cc
+++ b/nix/libstore/globals.cc
@@ -66,7 +66,6 @@ Settings::Settings()
void Settings::processEnvironment()
{
nixStore = canonPath(getEnv("NIX_STORE_DIR", getEnv("NIX_STORE", NIX_STORE_DIR)));
- nixDataDir = canonPath(getEnv("NIX_DATA_DIR", NIX_DATA_DIR));
nixLogDir = canonPath(getEnv("GUIX_LOG_DIRECTORY", NIX_LOG_DIR));
nixStateDir = canonPath(getEnv("GUIX_STATE_DIRECTORY", NIX_STATE_DIR));
nixDBPath = getEnv("GUIX_DATABASE_DIRECTORY", nixStateDir + "/db");
diff --git a/nix/libstore/globals.hh b/nix/libstore/globals.hh
index a6935c3337..b073f724b6 100644
--- a/nix/libstore/globals.hh
+++ b/nix/libstore/globals.hh
@@ -45,8 +45,6 @@ struct Settings {
/* The directory where we store sources and derived files. */
Path nixStore;
- Path nixDataDir; /* !!! fix */
-
/* The directory where we log various operations. */
Path nixLogDir;
diff --git a/nix/local.mk b/nix/local.mk
index fe45c344f0..ca958ff500 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -1,5 +1,5 @@
# GNU Guix --- Functional package management for GNU
-# Copyright © 2012, 2013, 2014, 2015, 2016, 2018 Ludovic Courtès <ludo@gnu.org>
+# Copyright © 2012, 2013, 2014, 2015, 2016, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
#
# This file is part of GNU Guix.
@@ -107,7 +107,6 @@ libstore_a_CPPFLAGS = \
-I$(top_srcdir)/%D%/libstore \
-I$(top_builddir)/%D%/libstore \
-DNIX_STORE_DIR=\"$(storedir)\" \
- -DNIX_DATA_DIR=\"$(datadir)\" \
-DNIX_STATE_DIR=\"$(localstatedir)/guix\" \
-DNIX_LOG_DIR=\"$(localstatedir)/log/guix\" \
-DGUIX_CONFIGURATION_DIRECTORY=\"$(sysconfdir)/guix\" \