summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/calendar.scm4
-rw-r--r--gnu/packages/certs.scm4
-rw-r--r--gnu/packages/cups.scm8
-rw-r--r--gnu/packages/databases.scm34
-rw-r--r--gnu/packages/dejagnu.scm4
-rw-r--r--gnu/packages/freedesktop.scm4
-rw-r--r--gnu/packages/gl.scm19
-rw-r--r--gnu/packages/gstreamer.scm107
-rw-r--r--gnu/packages/image.scm4
-rw-r--r--gnu/packages/imagemagick.scm4
-rw-r--r--gnu/packages/linux.scm4
-rw-r--r--gnu/packages/nss.scm6
-rw-r--r--gnu/packages/patches/mrustc-0.8.0-fix-variable-length-integer-receiving.patch15
-rw-r--r--gnu/packages/pretty-print.scm4
-rw-r--r--gnu/packages/python-xyz.scm4
-rw-r--r--gnu/packages/qt.scm11
-rw-r--r--gnu/packages/rust.scm73
-rw-r--r--gnu/packages/tls.scm4
-rw-r--r--gnu/packages/video.scm4
-rw-r--r--gnu/packages/xdisorg.scm4
-rw-r--r--gnu/packages/xorg.scm8
22 files changed, 183 insertions, 147 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 626d91ce62..448e70aa38 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1184,7 +1184,6 @@ dist_patch_DATA = \
%D%/packages/patches/mozjs38-tracelogger.patch \
%D%/packages/patches/mozjs38-version-detection.patch \
%D%/packages/patches/mrrescue-support-love-11.patch \
- %D%/packages/patches/mrustc-0.8.0-fix-variable-length-integer-receiving.patch \
%D%/packages/patches/mtools-mformat-uninitialized.patch \
%D%/packages/patches/mumps-build-parallelism.patch \
%D%/packages/patches/mumps-shared-libseq.patch \
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 5e7ac66260..5a88c98456 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -50,7 +50,7 @@
(define-public libical
(package
(name "libical")
- (version "3.0.6")
+ (version "3.0.7")
(source (origin
(method url-fetch)
(uri (string-append
@@ -58,7 +58,7 @@
version "/libical-" version ".tar.gz"))
(sha256
(base32
- "15sdmh8w4vszd7jhv9fdpd48anpkniq2k1jw7siy9v1jnz1232jw"))))
+ "1z33wzaazbd7drl6qbh1750whd78xl2cg0gjnxyya9m83vgndgha"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f ; test suite appears broken
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index 18be845eec..864fe5def1 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -76,7 +76,7 @@
(define-public nss-certs
(package
(name "nss-certs")
- (version "3.48")
+ (version "3.49.1")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -87,7 +87,7 @@
"nss-" version ".tar.gz")))
(sha256
(base32
- "1b7qs1q7jqhw9dvkdznanzhc5dyq4bwx0biywszy3qx4hqm8571z"))))
+ "0vh23g16ldvnsrn2dnvdl2i133kizi660r7ilb00vfq2kvj45anr"))))
(build-system gnu-build-system)
(outputs '("out"))
(native-inputs
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 0adca9addb..8fbb2ee4f6 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -58,7 +58,7 @@
(define-public cups-filters
(package
(name "cups-filters")
- (version "1.25.13")
+ (version "1.26.2")
(source(origin
(method url-fetch)
(uri
@@ -66,7 +66,7 @@
"cups-filters-" version ".tar.xz"))
(sha256
(base32
- "1z3b7p6pp6yzvzl2nip9q0gn4fr5k9qwpnnhqqkiaaf3b1nfswjj"))
+ "1a8x6zgw3m4717gw3842gsrgjl05q92xygy4rp5vwr1d1xjmyxp1"))
(modules '((guix build utils)))
(snippet
;; install backends, banners and filters to cups-filters output
@@ -187,7 +187,7 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
(define-public cups-minimal
(package
(name "cups-minimal")
- (version "2.3.0")
+ (version "2.3.1")
(source
(origin
(method url-fetch)
@@ -195,7 +195,7 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
version "/cups-" version "-source.tar.gz"))
(sha256
(base32
- "19d1jpdpxy0fclq37pchi7ldnw9dssxx3zskcgqai3h0rwlh5bxc"))))
+ "1kkpmj17205j8w9hdff2bfpk6lwdmr3gx0j4r35nhgvya24rvjhv"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index e90fdfef7c..d06d586f70 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -879,6 +879,11 @@ Language.")
(rename-file (string-append out "/bin/mysql_config")
(string-append dev "/bin/mysql_config"))
+
+ (substitute* (string-append out "/bin/mysql_install_db")
+ (("\\$basedir/share/mysql")
+ (string-append lib "/share/mysql")))
+
;; Embed an absolute reference to OpenSSL in mysql_config
;; and the pkg-config file to avoid propagation.
(substitute* (list (string-append dev "/bin/mysql_config")
@@ -914,33 +919,6 @@ Language.")
as a drop-in replacement of MySQL.")
(license license:gpl2)))
-;; TODO: mysql_install_db is broken in MariaDB. This package is here as
-;; a workaround for packages that need it. Merge with 'mariadb' in the next
-;; rebuild cycle.
-(define-public mariadb/fixed-install-db
- (hidden-package
- (package/inherit
- mariadb
- (name "mariadb-fixed")
- (native-inputs '())
- (inputs
- `(("mariadb" ,mariadb)
- ("mariadb:lib" ,mariadb "lib")))
- (outputs '("out"))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules ((guix build utils)))
- (let ((out (assoc-ref %outputs "out")))
- (copy-recursively (assoc-ref %build-inputs "mariadb") out)
- (substitute* (string-append out "/bin/mysql_install_db")
- (("\\$basedir/share/mysql")
- (string-append (assoc-ref %build-inputs "mariadb:lib")
- "/share/mysql")))
- #t)))))))
-
(define-public mariadb-connector-c
(package
(name "mariadb-connector-c")
@@ -3303,7 +3281,7 @@ simultaneous database connections by using this framework.")
`(;; For tests.
("inetutils" ,inetutils)
("glibc-locales" ,glibc-locales)
- ("mariadb" ,mariadb/fixed-install-db)))
+ ("mariadb" ,mariadb)))
(inputs
`(("libdbi" ,libdbi)
("mariadb:dev" ,mariadb "dev")
diff --git a/gnu/packages/dejagnu.scm b/gnu/packages/dejagnu.scm
index f2aca50f1a..0dee89dfc1 100644
--- a/gnu/packages/dejagnu.scm
+++ b/gnu/packages/dejagnu.scm
@@ -28,7 +28,7 @@
(define-public dejagnu
(package
(name "dejagnu")
- (version "1.6.1")
+ (version "1.6.2")
(source
(origin
(method url-fetch)
@@ -36,7 +36,7 @@
version ".tar.gz"))
(sha256
(base32
- "14hnq1mh91vqprc43xdy4f15sycw6fbajrh7zi6cw2kyg6xjhnxz"))))
+ "0qfj2wd4qk1yn9yzam6g8nmyxfazcc0knjyyibycb2ainkhp21hd"))))
(build-system gnu-build-system)
(inputs `(("expect" ,expect)))
(arguments
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index ed221439b4..205015bae1 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -180,14 +180,14 @@ freedesktop.org project.")
(define-public libinput
(package
(name "libinput")
- (version "1.14.3")
+ (version "1.15.0")
(source (origin
(method url-fetch)
(uri (string-append "https://freedesktop.org/software/libinput/"
"libinput-" version ".tar.xz"))
(sha256
(base32
- "1dy58j8dvr7ri34bx0lppmh5638m956azgwk501w373hi42kmsqg"))))
+ "1qa3b2fd4pv8ysf0mgwnyhqv9v48zgy3sy0q3a3vxcmwcvpizgxz"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Ddocumentation=false")
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 077b009688..42bed5d623 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -96,7 +96,7 @@ as ASCII text.")
(define-public freeglut
(package
(name "freeglut")
- (version "3.0.0")
+ (version "3.2.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -104,16 +104,15 @@ as ASCII text.")
version "/freeglut-" version ".tar.gz"))
(sha256
(base32
- "18knkyczzwbmyg8hr4zh8a1i5ga01np2jzd1rwmsh7mh2n2vwhra"))))
+ "0s6sk49q8ijgbsrrryb7dzqx2fa744jhx1wck5cz5jia2010w06l"))))
(build-system cmake-build-system)
- (arguments '(#:tests? #f)) ; no test target
- (inputs `(("mesa" ,mesa)
- ("libx11" ,libx11)
+ (arguments
+ '(#:tests? #f ;no test target
+ #:configure-flags '("-DFREEGLUT_BUILD_STATIC_LIBS=OFF")))
+ (inputs `(("libx11" ,libx11)
("libxi" ,libxi)
("libxrandr" ,libxrandr)
- ("libxxf86vm" ,libxxf86vm)
- ("xorgproto" ,xorgproto)
- ("xinput" ,xinput)))
+ ("libxxf86vm" ,libxxf86vm)))
(propagated-inputs
;; Headers from Mesa and GLU are needed.
`(("glu" ,glu)
@@ -230,7 +229,7 @@ also known as DXTn or DXTC) for Mesa.")
(define-public mesa
(package
(name "mesa")
- (version "19.2.7")
+ (version "19.3.2")
(source
(origin
(method url-fetch)
@@ -242,7 +241,7 @@ also known as DXTn or DXTC) for Mesa.")
version "/mesa-" version ".tar.xz")))
(sha256
(base32
- "17jp8ghipgz62vqqz5llskxypkcmgf8gnlgnj0pyvnbgi6vryyg3"))
+ "1hg1gvcwvayksrdh9z8rfz66h3z1ffspmm2qgyy2nd8n8qrfwfjf"))
(patches
(search-patches "mesa-skip-disk-cache-test.patch"))))
(build-system meson-build-system)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 63b4179bc6..1e26a3ce3e 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -116,19 +116,41 @@ arrays of data.")
(sha256
(base32
"0kp93622y29pck8asvil1fmzf55s2gx76wv475a6izc3cwj49w73"))))
- (build-system gnu-build-system)
+ (build-system meson-build-system)
(outputs '("out" "doc"))
(arguments
- `(#:configure-flags
- (list (string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))))
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; FIXME: Since switching to the meson-build-system, two tests
+ ;; started failing on i686. See
+ ;; <https://gitlab.freedesktop.org/gstreamer/gstreamer/issues/499>.
+ ,@(if (string-prefix? "i686" (or (%current-target-system)
+ (%current-system)))
+ `((add-after 'unpack 'disable-some-tests
+ (lambda _
+ (substitute* "tests/check/gst/gstsystemclock.c"
+ (("tcase_add_test \\(tc_chain, test_stress_cleanup_unschedule.*")
+ "")
+ (("tcase_add_test \\(tc_chain, test_stress_reschedule.*")
+ ""))
+ #t)))
+ '())
+ (add-after 'install 'move-docs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share"))
+ (copy-recursively (string-append out "/share/gtk-doc")
+ (string-append doc "/share/gtk-doc"))
+ (delete-file-recursively (string-append out "/share/gtk-doc"))
+ #t))))))
(propagated-inputs `(("glib" ,glib))) ; required by gstreamer-1.0.pc.
(native-inputs
`(("bison" ,bison)
("flex" ,flex)
("glib" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
+ ("gtk-doc" ,gtk-doc)
("perl" ,perl)
("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)))
@@ -163,8 +185,7 @@ This package provides the core library and elements.")
(sha256
(base32
"0sl1hxlyq46r02k7z70v09vx1gi4rcypqmzra9jid93lzvi76gmi"))))
- (build-system gnu-build-system)
- (outputs '("out" "doc"))
+ (build-system meson-build-system)
(propagated-inputs
`(("glib" ,glib) ;required by gstreamer-sdp-1.0.pc
("gstreamer" ,gstreamer) ;required by gstreamer-plugins-base-1.0.pc
@@ -198,11 +219,10 @@ This package provides the core library and elements.")
("gobject-introspection" ,gobject-introspection)
("python-wrapper" ,python-wrapper)))
(arguments
- `(#:parallel-tests? #f ; 'pipelines/tcp' fails in parallel
- #:configure-flags
- (list (string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))
+ '(#:configure-flags '("-Dgl=disabled"
+ ;; FIXME: Documentation fails to build without
+ ;; enabling GL above, which causes other problems.
+ "-Ddoc=false")
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch
@@ -230,7 +250,7 @@ for the GStreamer multimedia library.")
(sha256
(base32
"068k3cbv1yf3gbllfdzqsg263kzwh21y8dpwr0wvgh15vapkpfs0"))))
- (build-system gnu-build-system)
+ (build-system meson-build-system)
(inputs
`(("aalib" ,aalib)
("cairo" ,cairo)
@@ -263,6 +283,22 @@ for the GStreamer multimedia library.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ ,@(if (string-prefix? "arm" (or (%current-target-system)
+ (%current-system)))
+ ;; FIXME: These tests started failing on armhf after switching to Meson.
+ ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/issues/689
+ `((add-after 'unpack 'disable-tests-for-armhf
+ (lambda _
+ (substitute* "tests/check/elements/rtpbin_buffer_list.c"
+ (("tcase_add_test \\(tc_chain, test_bufferlist\\);")
+ ""))
+ (substitute* "tests/check/elements/rtpulpfec.c"
+ (("tcase_add_loop_test.*rtpulpfecdec_recovered_from_many.*")
+ "")
+ (("tcase_add.*rtpulpfecdec_recovered_using_recovered_packet.*")
+ ""))
+ #t)))
+ '())
(add-after
'unpack 'disable-failing-tests
(lambda _
@@ -291,19 +327,35 @@ developers consider to have good quality code and correct functionality.")
(sha256
(base32
"0x0y0hm0ga3zqi5q4090hw5sjh59y1ry9ak16qsaascm72i7mjzi"))))
- (outputs '("out" "doc"))
- (build-system gnu-build-system)
+ (build-system meson-build-system)
(arguments
- '(#:tests? #f ; XXX: 13 of 53 tests fail
- #:configure-flags
- (list (string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))))
+ `(#:phases
+ (modify-phases %standard-phases
+ ,@(if (string-prefix? "arm" (or (%current-target-system)
+ (%current-system)))
+ ;; Disable test that fails on ARMv7.
+ ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/issues/1188
+ `((add-after 'unpack 'disable-asfmux-test
+ (lambda _
+ (substitute* "tests/check/meson.build"
+ (("\\[\\['elements/asfmux\\.c'\\]\\],")
+ ""))
+ #t)))
+ '())
+ (add-after 'unpack 'disable-failing-test
+ (lambda _
+ ;; FIXME: Why is this failing.
+ (substitute* "tests/check/meson.build"
+ ((".*elements/dash_mpd\\.c.*")
+ ""))
+ #t)))))
(propagated-inputs
`(("gst-plugins-base" ,gst-plugins-base)))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection)
+ ;; TODO: Enable documentation for 1.18.
+ ;;("gtk-doc" ,gtk-doc)
("pkg-config" ,pkg-config)
("python" ,python)))
(inputs
@@ -367,7 +419,7 @@ par compared to the rest.")
(sha256
(base32
"1jpvc32x6q01zjkfgh6gmq6aaikiyfwwnhj7bmvn52syhrdl202m"))))
- (build-system gnu-build-system)
+ (build-system meson-build-system)
(inputs
`(("gst-plugins-base" ,gst-plugins-base)
("liba52" ,liba52)
@@ -408,9 +460,7 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
;; Drop bundled ffmpeg.
(delete-file-recursively "gst-libs/ext/libav")
#t))))
- (build-system gnu-build-system)
- (arguments
- '(#:configure-flags '("--with-system-libav")))
+ (build-system meson-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)
("python" ,python)))
@@ -438,15 +488,16 @@ compression formats through the use of the libav library.")
(sha256
(base32
"1a48ca66izmm8hnp608jv5isg3jxb0vlfmhns0bg9nbkilag7390"))))
- (build-system gnu-build-system)
+ (build-system meson-build-system)
(arguments
- `(#:modules ((guix build gnu-build-system)
+ `(#:modules ((guix build meson-build-system)
+ (guix build utils)
((guix build python-build-system) #:prefix python:))
- #:imported-modules (,@%gnu-build-system-modules
+ #:imported-modules (,@%meson-build-system-modules
(guix build python-build-system))
#:configure-flags
(list (string-append
- "--with-pygi-overrides-dir="
+ "-Dpygi-overrides-dir="
(python:site-packages %build-inputs %outputs) "gi/overrides"))))
(native-inputs
`(("pkg-config" ,pkg-config)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 45055858b4..a79d63fb5d 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1102,7 +1102,7 @@ language bindings to VIGRA.")
(define-public libwebp
(package
(name "libwebp")
- (version "1.0.3")
+ (version "1.1.0")
(source
(origin
;; No tarballs are provided for >0.6.1.
@@ -1113,7 +1113,7 @@ language bindings to VIGRA.")
(file-name (git-file-name name version))
(sha256
(base32
- "1l8h9d3z3kla567ilmymrgg8vc2n763g8qss1hah8dg832hbqkxf"))))
+ "0r2yy9if0ndvpzadk39bigvsygyqnlv0xjb9w2aj6rs534mncazz"))))
(build-system gnu-build-system)
(inputs
`(("freeglut" ,freeglut)
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index e6a178713a..2b4bc5680d 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -48,14 +48,14 @@
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.
- (version "6.9.10-78")
+ (version "6.9.10-87")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
(sha256
(base32
- "178sai7r0w2hwv01is25c8mxf9lc2ba0l16qm45h9vv49y5dy08q"))))
+ "09m0nx7y6j5cq13r583kp3lbsc357cc3q0kcvzbya54r5lx20a5p"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--with-frozenpaths" "--without-gcc-arch")
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 829bb09447..4f8400ba53 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1224,14 +1224,14 @@ by Robert Shea and Robert Anton Wilson.")
(define-public procps
(package
(name "procps")
- (version "3.3.15")
+ (version "3.3.16")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/procps-ng/Production/"
"procps-ng-" version ".tar.xz"))
(sha256
(base32
- "0r84kwa5fl0sjdashcn4vh7hgfm7ahdcysig3mcjvpmkzi7p9g8h"))))
+ "1br0g93ysqhlv13i1k4lfbimsgxnpy5rgs4lxfc9rkzdbpbaqplj"))))
(build-system gnu-build-system)
(arguments
'(#:modules ((guix build utils)
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 2e34f8e26f..294891734d 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -70,7 +70,7 @@ in the Mozilla clients.")
(define-public nss
(package
(name "nss")
- (version "3.48")
+ (version "3.49.1")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -81,7 +81,7 @@ in the Mozilla clients.")
"nss-" version ".tar.gz")))
(sha256
(base32
- "1b7qs1q7jqhw9dvkdznanzhc5dyq4bwx0biywszy3qx4hqm8571z"))
+ "0vh23g16ldvnsrn2dnvdl2i133kizi660r7ilb00vfq2kvj45anr"))
;; Create nss.pc and nss-config.
(patches (search-patches "nss-pkgconfig.patch"
"nss-freebl-stubs.patch"
@@ -130,7 +130,7 @@ in the Mozilla clients.")
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To
;; work around that, set the time to roughly the release date.
- (invoke "faketime" "2019-12-01" "./nss/tests/all.sh")))
+ (invoke "faketime" "2020-01-01" "./nss/tests/all.sh")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
diff --git a/gnu/packages/patches/mrustc-0.8.0-fix-variable-length-integer-receiving.patch b/gnu/packages/patches/mrustc-0.8.0-fix-variable-length-integer-receiving.patch
deleted file mode 100644
index 9e76653a07..0000000000
--- a/gnu/packages/patches/mrustc-0.8.0-fix-variable-length-integer-receiving.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-https://github.com/thepowersgang/mrustc/issues/109
-From: Danny Milosavljevic <dannym@scratchpost.org>
-Date: Fri, 3 Jan 2019 13:00:00 +0100
-
---- mrustc/src/expand/proc_macro.cpp.orig 2019-02-01 14:16:54.208486062 +0100
-+++ mrustc/src/expand/proc_macro.cpp 2019-02-01 14:17:14.350925705 +0100
-@@ -977,7 +977,7 @@
- for(;;)
- {
- auto b = recv_u8();
-- v |= static_cast<uint64_t>(b) << ofs;
-+ v |= static_cast<uint64_t>(b & 0x7F) << ofs;
- if( (b & 0x80) == 0 )
- break;
- ofs += 7;
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 6f2b3f78ea..fc98478d4c 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -190,7 +190,7 @@ to @code{IOStreams}.")
(define-public source-highlight
(package
(name "source-highlight")
- (version "3.1.8")
+ (version "3.1.9")
(source
(origin
(method url-fetch)
@@ -198,7 +198,7 @@ to @code{IOStreams}.")
version ".tar.gz"))
(sha256
(base32
- "18xdalxg7yzrxc1njzgw7aryq2jdm7zq2yqz41sc7k6il5z6lcq1"))))
+ "148w47k3zswbxvhg83z38ifi85f9dqcpg7icvvw1cm6bg21x4zrs"))))
(build-system gnu-build-system)
;; The ctags that comes with emacs does not support the --excmd options,
;; so can't be used
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 715a0109f7..583420e6fa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2638,14 +2638,14 @@ reStructuredText.")
(define-public python-pygments
(package
(name "python-pygments")
- (version "2.4.2")
+ (version "2.5.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Pygments" version))
(sha256
(base32
- "15v2sqm5g12bqa0c7wikfh9ck2nl97ayizy1hpqhmws5gqalq748"))))
+ "1zmhnswy0wxfn0xprs9aqsvx2c3kmzfn2wx14q8cv3vpkxdamj4q"))))
(build-system python-build-system)
(arguments
;; FIXME: Tests require sphinx, which depends on this.
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 9b59dc0f46..80570c00dd 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Mike Rosset <mike.rosset@gmail.com>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -364,6 +365,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
(build-system gnu-build-system)
(propagated-inputs
`(("mesa" ,mesa)
+ ;; Use which the package, not the function
("which" ,(@ (gnu packages base) which))))
(inputs
`(("alsa-lib" ,alsa-lib)
@@ -408,6 +410,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
("xcb-util-keysyms" ,xcb-util-keysyms)
("xcb-util-renderutil" ,xcb-util-renderutil)
("xcb-util-wm" ,xcb-util-wm)
+ ("xdg-utils" ,xdg-utils)
("zlib" ,zlib)))
(native-inputs
`(("bison" ,bison)
@@ -429,6 +432,14 @@ developers using C++ or QML, a CSS & JavaScript like language.")
"qmake/library/qmakebuiltins.cpp")
(("/bin/sh") (which "sh")))
#t))
+ (add-after 'configure 'patch-xdg-open
+ (lambda _
+ (substitute* '("src/platformsupport/services/genericunix/qgenericunixservices.cpp")
+ (("^.*const char \\*browsers.*$" all)
+ (string-append "*browser = QStringLiteral(\""
+ (which "xdg-open")
+ "\"); return true; \n" all)))
+ #t))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index cec565bbc8..8bed56ff72 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -91,7 +91,7 @@
(let ((rustc-version "1.19.0"))
(package
(name "mrustc")
- (version "0.8.0")
+ (version "0.9")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -100,57 +100,61 @@
(file-name (git-file-name name version))
(sha256
(base32
- "0a7v8ccyzp1sdkwni8h1698hxpfz2sxhcpx42n6l2pbm0rbjp08i"))
- (patches
- (search-patches "mrustc-0.8.0-fix-variable-length-integer-receiving.patch"))))
+ "194ny7vsks5ygiw7d8yxjmp1qwigd71ilchis6xjl6bb2sj97rd2"))))
(outputs '("out" "cargo"))
(build-system gnu-build-system)
(inputs
- `(("llvm" ,llvm-3.9.1)))
+ `(("zlib" ,zlib)))
(native-inputs
`(("bison" ,bison)
("flex" ,flex)
;; Required for the libstd sources.
("rustc" ,(package-source rust-1.19))))
(arguments
- `(#:test-target "local_tests"
- #:make-flags (list (string-append "LLVM_CONFIG="
- (assoc-ref %build-inputs "llvm")
- "/bin/llvm-config"))
+ `(#:test-target "test"
+ #:make-flags
+ (list ,(string-append "RUSTC_TARGET="
+ (or (%current-target-system)
+ (nix-system->gnu-triplet-for-rust))))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-date
(lambda _
(substitute* "Makefile"
(("shell date") "shell date -d @1"))
+ (substitute* "run_rustc/Makefile"
+ (("[$]Vtime ") "$V "))
#t))
(add-after 'patch-date 'unpack-target-compiler
(lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* "minicargo.mk"
- ;; Don't try to build LLVM.
- (("^[$][(]LLVM_CONFIG[)]:") "xxx:")
- ;; Build for the correct target architecture.
- (("^RUSTC_TARGET := x86_64-unknown-linux-gnu")
- (string-append "RUSTC_TARGET := "
- ,(or (%current-target-system)
- (nix-system->gnu-triplet-for-rust)))))
(invoke "tar" "xf" (assoc-ref inputs "rustc"))
- (chdir "rustc-1.19.0-src")
- (invoke "patch" "-p0" "../rust_src.patch")
+ (chdir ,(string-append "rustc-" rustc-version "-src"))
+ (invoke "patch" "-p0" ,(string-append "../rustc-" rustc-version
+ "-src.patch"))
(chdir "..")
+ (setenv "RUSTC_VERSION" ,rustc-version)
+ (setenv "MRUSTC_TARGET_VER"
+ ,(version-major+minor rustc-version))
+ (setenv "OUTDIR_SUF" "")
#t))
(replace 'configure
(lambda* (#:key inputs #:allow-other-keys)
- (setenv "CC" (string-append (assoc-ref inputs "gcc") "/bin/gcc"))
+ (setenv "CC" (string-append (assoc-ref inputs "gcc")
+ "/bin/gcc"))
+ (setenv "CXX" (string-append (assoc-ref inputs "gcc")
+ "/bin/g++"))
#t))
(add-after 'build 'build-minicargo
- (lambda _
- (for-each (lambda (target)
- (invoke "make" "-f" "minicargo.mk" target))
- '("output/libstd.hir" "output/libpanic_unwind.hir"
- "output/libproc_macro.hir" "output/libtest.hir"))
- ;; Technically the above already does it - but we want to be clear.
- (invoke "make" "-C" "tools/minicargo")))
+ (lambda* (#:key make-flags #:allow-other-keys)
+ ;; TODO: minicargo.mk: RUSTC_VERSION=$(RUSTC_VERSION) RUSTC_CHANNEL=$(RUSTC_SRC_TY) OUTDIR_SUF=$(OUTDIR_SUF)
+ (apply invoke "make" "-f" "minicargo.mk" "LIBS" make-flags)
+ (apply invoke "make" "-C" "tools/minicargo" make-flags)))
+ ;(add-after 'check 'check-locally
+ ; (lambda* (#:key make-flags #:allow-other-keys)
+ ; ;; The enum test wouldn't work otherwise.
+ ; ;; See <https://github.com/thepowersgang/mrustc/issues/137>.
+ ; (setenv "MRUSTC_TARGET_VER" ,(version-major+minor rustc-version))
+ ; (apply invoke "make" "local_tests" make-flags)))
(replace 'install
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -160,11 +164,13 @@
(cargo-bin (string-append cargo-out "/bin"))
(lib (string-append out "/lib"))
(lib/rust (string-append lib "/mrust"))
- (gcc (assoc-ref inputs "gcc")))
+ (gcc (assoc-ref inputs "gcc"))
+ (run_rustc (string-append out
+ "/share/mrustc/run_rustc")))
;; These files are not reproducible.
(for-each delete-file (find-files "output" "\\.txt$"))
- (delete-file-recursively "output/local_tests")
- (mkdir-p lib)
+ ;(delete-file-recursively "output/local_tests")
+ (mkdir-p (dirname lib/rust))
(copy-recursively "output" lib/rust)
(mkdir-p bin)
(mkdir-p tools-bin)
@@ -172,6 +178,9 @@
;; minicargo uses relative paths to resolve mrustc.
(install-file "tools/bin/minicargo" tools-bin)
(install-file "tools/bin/minicargo" cargo-bin)
+ (mkdir-p run_rustc)
+ (copy-file "run_rustc/Makefile"
+ (string-append run_rustc "/Makefile"))
#t))))))
(synopsis "Compiler for the Rust progamming language")
(description "Rust is a systems programming language that provides memory
@@ -289,8 +298,12 @@ test = { path = \"../libtest\" }
(setenv "CFG_RELEASE_CHANNEL" "stable")
(setenv "CFG_LIBDIR_RELATIVE" "lib")
(setenv "CFG_VERSION" "1.19.0-stable-mrustc")
+ (setenv "MRUSTC_TARGET_VER" ,(version-major+minor version))
; bad: (setenv "CFG_PREFIX" "mrustc") ; FIXME output path.
(mkdir-p "output")
+ ;; mrustc 0.9 doesn't check the search paths for crates anymore.
+ (copy-recursively (string-append rustc-bootstrap "/lib/mrust")
+ "output")
(invoke (string-append rustc-bootstrap "/tools/bin/minicargo")
"src/rustc" "--vendor-dir" "src/vendor"
"--output-dir" "output/rustc-build"
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 10d864348c..ece880f2f2 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -424,7 +424,7 @@ required structures.")
(package
(inherit openssl)
(name "openssl")
- (version "1.0.2t")
+ (version "1.0.2u")
(source (origin
(method url-fetch)
(uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -436,7 +436,7 @@ required structures.")
"/openssl-" version ".tar.gz")))
(sha256
(base32
- "1g67ra0ph7gpz6fgvv1i96d792jmd6ymci5kk53vbikszr74djql"))
+ "05lxcs4hzyfqd5jn0d9p0fvqna62v2s4pc9qgmq0dpcknkzwdl7c"))
(patches (search-patches "openssl-runpath.patch"
"openssl-c-rehash-in.patch"))))
(outputs '("out"
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ee7108753f..730d5a408f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -738,7 +738,7 @@ libebml is a C++ library to read and write EBML files.")
(define-public libva
(package
(name "libva")
- (version "2.5.0")
+ (version "2.6.1")
(source
(origin
(method url-fetch)
@@ -750,7 +750,7 @@ libebml is a C++ library to read and write EBML files.")
(string-append "https://www.freedesktop.org/software/vaapi/releases/"
"libva/libva-" version "/libva-" version ".tar.bz2")))
(sha256
- (base32 "0y38mw1ggxm15zq06r4qpwhd5wx4bppw1rsxpr6sq1m5d79rra1s"))))
+ (base32 "19df3r02k1p4cbyvifkdjyc8q7hi23f5b3x3390z52l25mjfnmvc"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 0f47821b7e..e79404ca7a 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -302,14 +302,14 @@ avoiding password prompts when X11 forwarding has already been setup.")
(define-public libxkbcommon
(package
(name "libxkbcommon")
- (version "0.9.1")
+ (version "0.10.0")
(source (origin
(method url-fetch)
(uri (string-append "https://xkbcommon.org/download/libxkbcommon-"
version ".tar.xz"))
(sha256
(base32
- "1q4v378sr9ad8fy9znl7k8xpf0wch655r9m6z0bcc7sw1azsminl"))))
+ "1wmnl0hngn6vrqrya4r8hvimlkr4jag39yjprls4gyrqvh667hsp"))))
(build-system meson-build-system)
(inputs
`(("libx11" ,libx11)
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 2392dc1cba..cd6c3218a8 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -3692,7 +3692,7 @@ alternative implementations like XRandR or TwinView.")
(define-public xinput
(package
(name "xinput")
- (version "1.6.2")
+ (version "1.6.3")
(source
(origin
(method url-fetch)
@@ -3702,7 +3702,7 @@ alternative implementations like XRandR or TwinView.")
".tar.bz2"))
(sha256
(base32
- "1i75mviz9dyqyf7qigzmxq8vn31i86aybm662fzjz5c086dx551n"))))
+ "1vb6xdd1xmk5f7pwc5zcbxfray5sf1vbnscqwf2yl8lv7gfq38im"))))
(build-system gnu-build-system)
(inputs
`(("libxrender" ,libxrender)
@@ -3837,7 +3837,7 @@ extension to the X11 protocol. It includes:
(define-public xkeyboard-config
(package
(name "xkeyboard-config")
- (version "2.27")
+ (version "2.28")
(source
(origin
(method url-fetch)
@@ -3847,7 +3847,7 @@ extension to the X11 protocol. It includes:
".tar.bz2"))
(sha256
(base32
- "07wh443lhwv1j0q6xnxnji7f7ahh7xphxj90fv02cdd6zv4aw3b9"))))
+ "1kmxc8hdw4qpvdlzp4ag8ygl34lqhs6sn3pcz1sl0kn61xdv5bb9"))))
(build-system gnu-build-system)
(inputs
`(("gettext" ,gettext-minimal)