summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c30532266c..068b17fdab 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10972,6 +10972,16 @@ hardware-accelerated multitouch applications.")
(base32
"0qc006986rb6bcbmiymwgcl1mns2jphr1j7sr7nk41nlr7gh359m"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-test
+ (lambda _
+ ;; TypeError: binary() got an unexpected keyword argument
+ ;; 'average_size'.
+ (substitute* "tests/test_check.py"
+ (("average_size=512") ""))
+ #t)))))
(propagated-inputs
`(("python-chardet" ,python-chardet)
("python-hypothesis" ,python-hypothesis)))