summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 5efce7388d..577ecb8a0e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8307,6 +8307,17 @@ between 2 and 3 times faster than the Mersenne Twister.")
(base32
"0w4hf598lpxfg58rnimcqxrbnpqq2jmpjx82qa5md3q6r90hlipd"))))
(build-system haskell-build-system)
+ ;; The limits have been adjusted in a revision of the cabal file.
+ (arguments
+ '(#:configure-flags (list "--allow-newer=vector")
+ #:phases
+ (modify-phases %standard-phases
+ ;; The tests cannot be built due to type errors.
+ (add-after 'unpack 'do-not-build-quickcheck-tests
+ (lambda _
+ (substitute* "vector-algorithms.cabal"
+ (("\\!flag\\(properties\\)") "True"))
+ #t)))))
(inputs
`(("ghc-vector" ,ghc-vector)
("ghc-mtl" ,ghc-mtl)