summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnupg.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index ddb9bf161d..90b5c2d72e 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -284,7 +284,20 @@ libskba (working with X.509 certificates and CMS data).")
(lambda _
(substitute* "tests/openpgp/Makefile.in"
(("/bin/sh") (which "bash")))
- #t)))))))
+ #t))
+ (add-after 'install 'rename-v2-commands
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Upstream suggests removing the trailing '2' from command names:
+ ;; <http://debbugs.gnu.org/cgi/bugreport.cgi?bug=22883#58>.
+ (let ((out (assoc-ref outputs "out")))
+ (with-directory-excursion (string-append out "/bin")
+ (rename-file "gpgv2" "gpgv")
+ (rename-file "gpg2" "gpg")
+
+ ;; Keep the old name around to ease transition.
+ (symlink "gpgv" "gpgv2")
+ (symlink "gpg" "gpg2")
+ #t)))))))))
(define-public gnupg-1
(package (inherit gnupg)