summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 02f1b91392..e17933b36f 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -520,8 +520,8 @@ with the Linux kernel.")
#:phases
(alist-replace
'unpack
- (lambda* (#:key inputs #:allow-other-keys)
- (and (zero? (system* "tar" "xvf" (assoc-ref inputs "source")))
+ (lambda* (#:key source inputs #:allow-other-keys)
+ (and (zero? (system* "tar" "xvf" source))
(zero? (system* "tar" "xvf" (assoc-ref inputs "tzcode")))))
(alist-cons-after
'install 'post-install