summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6013c31acb..40c6077951 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11929,10 +11929,18 @@ ignoring formatting changes.")
"Make loops show a progress bar on the console by just wrapping any
iterable with @code{|tqdm(iterable)|}. Offers many options to define
design and layout.")
- (license (list license:mpl2.0 license:expat))))
+ (license (list license:mpl2.0 license:expat))
+ (properties `((python2-variant . ,(delay python2-tqdm))))))
(define-public python2-tqdm
- (package-with-python2 python-tqdm))
+ (let ((tqdm (package-with-python2
+ (strip-python2-variant python-tqdm))))
+ (package
+ (inherit tqdm)
+ (native-inputs
+ ;; FIXME: This should be propagated from python2-flake8 instead.
+ `(("python2-enum34" ,python2-enum34)
+ ,@(package-native-inputs tqdm))))))
(define-public python-pkginfo
(package