summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/r-fix-15899.patch17
-rw-r--r--gnu/packages/statistics.scm5
2 files changed, 2 insertions, 20 deletions
diff --git a/gnu/packages/patches/r-fix-15899.patch b/gnu/packages/patches/r-fix-15899.patch
deleted file mode 100644
index 40593d34e6..0000000000
--- a/gnu/packages/patches/r-fix-15899.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Without the "extern" keyword external applications linking against R (such as
-Shogun, for example) might not be linkable.
-
-See https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=15899 for details
-about this bug.
-
---- a/src/include/Rinterface.h (revision 66251)
-+++ b/src/include/Rinterface.h (working copy)
-@@ -84,7 +84,7 @@
- void fpu_setup(Rboolean);
-
- /* in unix/system.c */
--int R_running_as_main_program;
-+extern int R_running_as_main_program;
-
- #ifdef CSTACK_DEFNS
- /* duplicating Defn.h */
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 0b9e081c69..91d988ebd4 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -42,7 +42,7 @@
(define-public r
(package
(name "r")
- (version "3.2.0")
+ (version "3.2.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cran/src/base/R-"
@@ -50,8 +50,7 @@
version ".tar.gz"))
(sha256
(base32
- "0dagyqgvi8i3nw158qi2zpwm04s4ffzvnmk5niaksvxs30zrbbpm"))
- (patches (list (search-patch "r-fix-15899.patch")))))
+ "10n9yhs55v1nnmdgsrgfncw29vq3ly70n8gvy1f4lq7l0hzvr7fm"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags