summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6410a13df7..2538505472 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3230,7 +3230,12 @@ provides additional functionality on the produced Mallard documents.")
(replace 'check
(lambda _
- (invoke "python" "runtests.py" "-vv"))))))
+ ;; Disable compiler optimizations to greatly reduce the running
+ ;; time of the test suite.
+ (setenv "CFLAGS" "-O0")
+
+ (invoke "python" "runtests.py" "-vv"
+ "-j" (number->string (parallel-job-count))))))))
(home-page "https://cython.org/")
(synopsis "C extensions for Python")
(description "Cython is an optimising static compiler for both the Python