summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fd1a2d3601..05c1f504ef 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -175,6 +175,24 @@
(("/bin/sh") (which "sh")))
#t))
(add-before
+ 'install 'do-not-record-configure-flags
+ (lambda _
+ ;; Remove configure flags from '_sysconfigdata.py' so we don't
+ ;; end up keeping references to the build tools.
+ (substitute* (find-files "." "sysconfigdata\\.py$")
+ (("'CONFIG_ARGS':.*")
+ "'CONFIG_ARGS': \"\",\n"))
+ #t))
+ (add-after
+ 'install 'do-not-record-configure-flags-in-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Likewise.
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* (find-files out "^Makefile$")
+ (("^CONFIG_ARGS[[:blank:]]*=.*$")
+ "CONFIG_ARGS =\n"))
+ #t)))
+ (add-before
'check 'pre-check
(lambda _
;; 'Lib/test/test_site.py' needs a valid $HOME