summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c29f1bf1d9..d1edef698e 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1219,6 +1219,28 @@ Haskell.")
modifying, and extracting files from zip archives in Haskell.")
(license bsd-3)))
+(define-public ghc-cereal
+ (package
+ (name "ghc-cereal")
+ (version "0.4.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/cereal/cereal-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "15rhfn9hrjm01ksh9xpz9syxsp9vkvpp6b736iqq38wv2wb7416z"))))
+ (build-system haskell-build-system)
+ (home-page "http://hackage.haskell.org/package/cereal")
+ (synopsis "Binary serialization library")
+ (description "This package provides a binary serialization library,
+similar to @code{binary}, that introduces an @code{isolate} primitive for
+parser isolation, and labeled blocks for better error messages.")
+ (license bsd-3)))
+
(define-public ghc-appar
(package
(name "ghc-appar")