summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ba1e0c424d..4215c3dc7f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11212,8 +11212,18 @@ replay them during future tests. It is designed to work with python-requests.")
(base32
"1jivjkp3xqif9gzr5fiq28jsskmh50vzzd7ldsb4rbyiw1iyv3hy"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ ;; 7 of the 'integration' tests require network access or login
+ ;; credentials.
+ (zero? (system* "nosetests" "--exclude=integration")))))))
(native-inputs
- `(("python-docutils" ,python-docutils)))
+ `(("python-docutils" ,python-docutils)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
(inputs
`(("python-botocore" ,python-botocore)))
(synopsis "Amazon S3 Transfer Manager")