summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile-xyz.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 877551ea3b..a8352380f7 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2187,12 +2187,23 @@ serializing continuations or delimited continuations.")
(build-system gnu-build-system)
(arguments
`(#:parallel-build? #f ; not supported
- #:make-flags
- '("GUILE_AUTO_COMPILE=0") ; to prevent guild errors
+ #:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
+
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'chdir
- (lambda _ (chdir "modules") #t)))))
+ (lambda _ (chdir "modules") #t))
+ (add-after 'install 'wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Wrap the 'python' executable so it can find its
+ ;; dependencies.
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/python")
+ `("GUILE_LOAD_PATH" ":" prefix
+ (,(getenv "GUILE_LOAD_PATH")))
+ `("GUILE_LOAD_COMPILED_PATH" ":" prefix
+ (,(getenv "GUILE_LOAD_COMPILED_PATH"))))
+ #t))))))
(inputs
`(("guile" ,guile-2.2)))
(propagated-inputs