summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/perl-tk-x11-discover.patch14
-rw-r--r--gnu/packages/tcl.scm4
2 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/patches/perl-tk-x11-discover.patch b/gnu/packages/patches/perl-tk-x11-discover.patch
new file mode 100644
index 0000000000..f4365e6882
--- /dev/null
+++ b/gnu/packages/patches/perl-tk-x11-discover.patch
@@ -0,0 +1,14 @@
+On non-x86_64 systems, this conditional can cause a specified X11 build value
+to be overwritten to null, causing x11 discovery to fail.
+
+--- a/myConfig 2014-05-12 11:16:48.152719722 -0500
++++ b/myConfig 2014-05-12 11:16:24.704719113 -0500
+@@ -350,7 +350,7 @@
+ #
+ # Prefer 64bit libraries on certain architectures
+ #
+- unless (defined $xlib and $Config{'archname'} =~ m/x86_64/)
++ unless (defined $xlib or not $Config{'archname'} =~ m/x86_64/)
+ {
+ $xlib64 = &lX11(0, chooseX11(</usr/X11*/lib64>));
+ }
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index eb4c227049..4859c2be72 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -23,6 +23,7 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system perl)
+ #:use-module (gnu packages)
#:use-module (gnu packages libpng)
#:use-module (gnu packages libjpeg)
#:use-module (gnu packages perl)
@@ -177,7 +178,8 @@ X11 GUIs.")
version ".tar.gz"))
(sha256
(base32
- "0jarvplhfvnm0shhdm2a5zczlnk9mkf8jvfjiwyhjrr3cy1gl0w0"))))
+ "0jarvplhfvnm0shhdm2a5zczlnk9mkf8jvfjiwyhjrr3cy1gl0w0"))
+ (patches (list (search-patch "perl-tk-x11-discover.patch")))))
(build-system perl-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs `(("libx11" ,libx11)