summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ec1c080607..801611beb1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -816,14 +816,10 @@ libpanel, librsvg and quartz.")
(let ((doc (string-append (assoc-ref outputs "doc")
"/share/doc/unison")))
(mkdir-p doc)
- ;; This is a workaround to prevent a build failure. Running
- ;; make docs somehow allows it to pass, but the generated
- ;; documentation is not pretty.
- (catch #t
- (lambda _
- (invoke "make" "docs"
- "TEXDIRECTIVES=\\\\draftfalse"))
- (lambda _ #t))
+ ;; Remove an '\n' that prevents the doc to be generated
+ ;; correctly with newer hevea.
+ (substitute* "doc/local.tex"
+ (("----SNIP----.*") "----SNIP----"))
;; This file needs write-permissions, because it's
;; overwritten by 'docs' during documentation generation.
(chmod "src/strings.ml" #o600)