summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5324da7568..2f146b545d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -974,6 +974,42 @@ so that other code can determine that it is running under XeTeX. The package
requires the e-TeX extensions to the TeX primitive set.")
(license license:lppl1.3c+)))
+(define-public texlive-generic-epsf
+ (package
+ (name "texlive-generic-epsf")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/generic/epsf"))
+ (revision %texlive-revision)))
+ (sha256
+ (base32
+ "14w3j81ympyvg8hkk9i1xgr8a0gfnfsb2ki8qqsk5pa051za1xcy"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/generic/epfs")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "http://www.ctan.org/pkg/epsf")
+ (synopsis "Simple macros for EPS inclusion")
+ (description
+ "This package provides the original (and now obsolescent) graphics
+inclusion macros for use with dvips, still widely used by Plain TeX users (in
+particular). For LaTeX users, the package is nowadays (rather strongly)
+deprecated in favour of the more sophisticated standard LaTeX latex-graphics
+bundle of packages. (The latex-graphics bundle is also available to Plain TeX
+users, via its Plain TeX version.)")
+ (license license:public-domain)))
+
(define-public texlive-latex-fancyvrb
(package
(name "texlive-latex-fancyvrb")