summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm23
-rw-r--r--gnu/packages/image.scm23
2 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 44419d9bcf..426866e6c3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -13611,6 +13611,29 @@ principal component analysis, correspondence analysis, spectral map
analysis.")
(license license:gpl2+)))
+(define-public r-png
+ (package
+ (name "r-png")
+ (version "0.1-7")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "png" version))
+ (sha256
+ (base32
+ "0g2mcp55lvvpx4kd3mn225mpbxqcq73wy5qx8b4lyf04iybgysg2"))))
+ (build-system r-build-system)
+ (inputs
+ `(("libpng" ,libpng)
+ ("zlib" ,zlib)))
+ (home-page "http://www.rforge.net/png/")
+ (synopsis "Read and write PNG images")
+ (description
+ "This package provides an easy and simple way to read, write and display
+bitmap images stored in the PNG format. It can read and write both files and
+in-memory raw vectors.")
+ ;; Any of these GPL versions.
+ (license (list license:gpl2 license:gpl3))))
+
(define-public r-ggcorrplot
(package
(name "r-ggcorrplot")
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index b52b6025ae..d363c445b7 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -198,29 +198,6 @@ APNG patch provides APNG support to libpng.")
(base32
"1izw9ybm27llk8531w6h4jp4rk2rxy2s9vil16nwik5dp0amyqxl"))))))
-(define-public r-png
- (package
- (name "r-png")
- (version "0.1-7")
- (source (origin
- (method url-fetch)
- (uri (cran-uri "png" version))
- (sha256
- (base32
- "0g2mcp55lvvpx4kd3mn225mpbxqcq73wy5qx8b4lyf04iybgysg2"))))
- (build-system r-build-system)
- (inputs
- `(("libpng" ,libpng)
- ("zlib" ,zlib)))
- (home-page "http://www.rforge.net/png/")
- (synopsis "Read and write PNG images")
- (description
- "This package provides an easy and simple way to read, write and display
-bitmap images stored in the PNG format. It can read and write both files and
-in-memory raw vectors.")
- ;; Any of these GPL versions.
- (license (list license:gpl2 license:gpl3))))
-
(define-public pngcrush
(package
(name "pngcrush")