summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/certs.scm4
-rw-r--r--gnu/packages/gl.scm15
-rw-r--r--gnu/packages/nss.scm6
-rw-r--r--gnu/packages/xorg.scm8
4 files changed, 16 insertions, 17 deletions
diff --git a/gnu/packages/certs.scm b/gnu/packages/certs.scm
index 18be845eec..1736d20c7e 100644
--- a/gnu/packages/certs.scm
+++ b/gnu/packages/certs.scm
@@ -76,7 +76,7 @@
(define-public nss-certs
(package
(name "nss-certs")
- (version "3.48")
+ (version "3.49")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -87,7 +87,7 @@
"nss-" version ".tar.gz")))
(sha256
(base32
- "1b7qs1q7jqhw9dvkdznanzhc5dyq4bwx0biywszy3qx4hqm8571z"))))
+ "07g7pn0r29y2h5p2zibz273yhkx6k4wvy8m1308hcqzxqi6hjf37"))))
(build-system gnu-build-system)
(outputs '("out"))
(native-inputs
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 077b009688..23904a556b 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -96,7 +96,7 @@ as ASCII text.")
(define-public freeglut
(package
(name "freeglut")
- (version "3.0.0")
+ (version "3.2.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -104,16 +104,15 @@ as ASCII text.")
version "/freeglut-" version ".tar.gz"))
(sha256
(base32
- "18knkyczzwbmyg8hr4zh8a1i5ga01np2jzd1rwmsh7mh2n2vwhra"))))
+ "0s6sk49q8ijgbsrrryb7dzqx2fa744jhx1wck5cz5jia2010w06l"))))
(build-system cmake-build-system)
- (arguments '(#:tests? #f)) ; no test target
- (inputs `(("mesa" ,mesa)
- ("libx11" ,libx11)
+ (arguments
+ '(#:tests? #f ;no test target
+ #:configure-flags '("-DFREEGLUT_BUILD_STATIC_LIBS=OFF")))
+ (inputs `(("libx11" ,libx11)
("libxi" ,libxi)
("libxrandr" ,libxrandr)
- ("libxxf86vm" ,libxxf86vm)
- ("xorgproto" ,xorgproto)
- ("xinput" ,xinput)))
+ ("libxxf86vm" ,libxxf86vm)))
(propagated-inputs
;; Headers from Mesa and GLU are needed.
`(("glu" ,glu)
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 2e34f8e26f..2df4af9d50 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -70,7 +70,7 @@ in the Mozilla clients.")
(define-public nss
(package
(name "nss")
- (version "3.48")
+ (version "3.49")
(source (origin
(method url-fetch)
(uri (let ((version-with-underscores
@@ -81,7 +81,7 @@ in the Mozilla clients.")
"nss-" version ".tar.gz")))
(sha256
(base32
- "1b7qs1q7jqhw9dvkdznanzhc5dyq4bwx0biywszy3qx4hqm8571z"))
+ "07g7pn0r29y2h5p2zibz273yhkx6k4wvy8m1308hcqzxqi6hjf37"))
;; Create nss.pc and nss-config.
(patches (search-patches "nss-pkgconfig.patch"
"nss-freebl-stubs.patch"
@@ -130,7 +130,7 @@ in the Mozilla clients.")
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To
;; work around that, set the time to roughly the release date.
- (invoke "faketime" "2019-12-01" "./nss/tests/all.sh")))
+ (invoke "faketime" "2020-01-01" "./nss/tests/all.sh")))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 022cb49c20..706faff32e 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -3692,7 +3692,7 @@ alternative implementations like XRandR or TwinView.")
(define-public xinput
(package
(name "xinput")
- (version "1.6.2")
+ (version "1.6.3")
(source
(origin
(method url-fetch)
@@ -3702,7 +3702,7 @@ alternative implementations like XRandR or TwinView.")
".tar.bz2"))
(sha256
(base32
- "1i75mviz9dyqyf7qigzmxq8vn31i86aybm662fzjz5c086dx551n"))))
+ "1vb6xdd1xmk5f7pwc5zcbxfray5sf1vbnscqwf2yl8lv7gfq38im"))))
(build-system gnu-build-system)
(inputs
`(("libxrender" ,libxrender)
@@ -3837,7 +3837,7 @@ extension to the X11 protocol. It includes:
(define-public xkeyboard-config
(package
(name "xkeyboard-config")
- (version "2.27")
+ (version "2.28")
(source
(origin
(method url-fetch)
@@ -3847,7 +3847,7 @@ extension to the X11 protocol. It includes:
".tar.bz2"))
(sha256
(base32
- "07wh443lhwv1j0q6xnxnji7f7ahh7xphxj90fv02cdd6zv4aw3b9"))))
+ "1kmxc8hdw4qpvdlzp4ag8ygl34lqhs6sn3pcz1sl0kn61xdv5bb9"))))
(build-system gnu-build-system)
(inputs
`(("gettext" ,gettext-minimal)