summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/netsurf-system-utf8proc.patch51
-rw-r--r--gnu/packages/web.scm16
2 files changed, 26 insertions, 41 deletions
diff --git a/gnu/packages/patches/netsurf-system-utf8proc.patch b/gnu/packages/patches/netsurf-system-utf8proc.patch
index 254bf52c93..654d45d017 100644
--- a/gnu/packages/patches/netsurf-system-utf8proc.patch
+++ b/gnu/packages/patches/netsurf-system-utf8proc.patch
@@ -28,37 +28,22 @@ Work around upstream's lack of a pkg-config file and update API.
#include "utils/errors.h"
#include "utils/idna.h"
-@@ -250,7 +250,7 @@
- return NSERROR_NOMEM;
- }
-
-- nfc_size = utf8proc_normalise(nfc_label, nfc_size,
-+ nfc_size = utf8proc_normalize_utf32(nfc_label, nfc_size,
- UTF8PROC_STABLE | UTF8PROC_COMPOSE);
- if (nfc_size < 0) {
- return NSERROR_NOMEM;
-@@ -565,7 +565,7 @@
- }
-
- /* Perform NFC normalisation */
-- ucs4_len = utf8proc_normalise(ucs4, u_ucs4_len,
-+ ucs4_len = utf8proc_normalize_utf32(ucs4, u_ucs4_len,
- UTF8PROC_STABLE | UTF8PROC_COMPOSE);
- if (ucs4_len < 0) {
- free(ucs4);
---- netsurf-3.6/test/Makefile
-+++ netsurf-3.6/test/Makefile
-@@ -112,11 +112,11 @@
- -D_XOPEN_SOURCE=600 \
- -Itest -Iinclude -Icontent/handlers -Ifrontends -I. -I.. \
- -Dnsgtk \
-- $(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc libidn) \
-+ $(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils libidn) \
- $(LIB_CFLAGS) \
- $(COV_CFLAGS)
-
--TESTLDFLAGS := $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc libidn) -lz \
-+TESTLDFLAGS := $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils libidn) -lz -lutf8proc \
- $(LIB_LDFLAGS)\
- $(COV_LDFLAGS)
+--- netsurf-3.7/test/Makefile 2017-10-15 08:39:24.000000000 -0500
++++ netsurf-3.7/test/Makefile 2017-11-05 11:14:46.219013218 -0600
+@@ -139,14 +139,14 @@
+ -D_XOPEN_SOURCE=600 \
+ -Itest -Iinclude -Icontent/handlers -Ifrontends -I. -I.. \
+ -Dnsgtk \
+- $(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc) \
++ $(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils) \
+ $(LIB_CFLAGS)
+ TESTCFLAGS := $(BASE_TESTCFLAGS) \
+ $(COV_CFLAGS) \
+ $(COV_CPPFLAGS)
+
+ TESTLDFLAGS := -L$(TESTROOT) \
+- $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc) -lz \
++ $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils) -lz -lutf8proc \
+ $(LIB_LDFLAGS)\
+ $(COV_LDFLAGS)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index e915fdd0cc..f49a4e55f7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4340,7 +4340,7 @@ developed as part of the Netsurf project.")
(define-public libcss
(package
(name "libcss")
- (version "0.6.0")
+ (version "0.7.0")
(source
(origin
(method url-fetch)
@@ -4348,7 +4348,7 @@ developed as part of the Netsurf project.")
name "-" version "-src.tar.gz"))
(sha256
(base32
- "0qp4p1q1dwgdra4pkrzd081zjzisxkgwx650ijx323j8bj725daf"))))
+ "16mns3h8vj7iw8myvgnw58q84irvbjlvfkxh8mdw6fbkjvaa7cnz"))))
(build-system gnu-build-system)
(native-inputs
`(("netsurf-buildsystem" ,netsurf-buildsystem)
@@ -4527,7 +4527,7 @@ Public Suffix List. It is developed as part of the NetSurf project.")
(define-public nsgenbind
(package
(name "nsgenbind")
- (version "0.4")
+ (version "0.5")
(source
(origin
(method url-fetch)
@@ -4535,7 +4535,7 @@ Public Suffix List. It is developed as part of the NetSurf project.")
name "-" version "-src.tar.gz"))
(sha256
(base32
- "078gpbfcs96bgcba0ygha0ph9jzqr6ry5s3a8p6sl61px2908s66"))))
+ "1iwjpdaan0njlhb9ir6a2q5vpxfmkqfldkvnqszqdz50b44vd1jv"))))
(build-system gnu-build-system)
(native-inputs
`(("netsurf-buildsystem" ,netsurf-buildsystem)
@@ -4555,7 +4555,7 @@ w3c webidl files and a binding configuration file.")
(define-public netsurf
(package
(name "netsurf")
- (version "3.6")
+ (version "3.7")
(source
(origin
(method url-fetch)
@@ -4563,7 +4563,7 @@ w3c webidl files and a binding configuration file.")
"releases/source/netsurf-" version "-src.tar.gz"))
(sha256
(base32
- "174sjx0566agckwmlj4w2cip5qbxdiafyhlp185a1qprxx84pbjr"))
+ "05kynfzzwd4fc03vbqdjpghh5xnk2yrh43w7vikak89vla30mhpg"))
(patches (search-patches "netsurf-system-utf8proc.patch"
"netsurf-y2038-tests.patch"
"netsurf-longer-test-timeout.patch"))))
@@ -4652,10 +4652,10 @@ w3c webidl files and a binding configuration file.")
(copy-file "frontends/gtk/res/netsurf-gtk.desktop"
desktop)
(substitute* desktop
- (("netsurf-gtk") (string-append out "/bin/netsurf"))
+ (("netsurf-gtk") (string-append out "/bin/netsurf-gtk"))
(("netsurf.png") (string-append out "/share/netsurf/"
"netsurf.xpm")))
- (install-file "Docs/netsurf-gtk.1"
+ (install-file "docs/netsurf-gtk.1"
(string-append out "/share/man/man1/"))
#t))))))
(home-page "http://www.netsurf-browser.org")