summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/base.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 502684ff40..422424cbe8 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -160,6 +160,13 @@ implementation offers several extensions over the standard utility.")
(("/bin/sh")
(string-append bash "/bin/sh")))
#t))))))
+
+ ;; When cross-compiling, the 'set-shell-file-name' phase needs to be able
+ ;; to refer to the target Bash.
+ (inputs (if (%current-target-system)
+ `(("bash" ,bash))
+ '()))
+
(synopsis "Managing tar archives")
(description
"Tar provides the ability to create tar archives, as well as the