summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm147
1 files changed, 6 insertions, 141 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 41c6a03932..fcefebffc5 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -41,148 +41,11 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages xml)
- #:use-module (gnu packages ncurses))
+ #:use-module (gnu packages ncurses)
+ #:use-module (gnu packages xdisorg))
-;; packages outside the x.org system proper
-
-(define-public xeyes
- (package
- (name "xeyes")
- (version "1.0.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://xeyes.sourcearchive.com/downloads/1.0.1/xeyes_"
- version
- ".orig.tar.gz"))
- (sha256
- (base32
- "04c3md570j67g55h3bix1qbngcslnq91skli51k3g1avki88zkm9"))))
- (build-system gnu-build-system)
- (inputs
- `(("libxext" ,libxext)
- ("libxmu" ,libxmu)
- ("libxt" ,libxt)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (home-page "http://xeyes.sourcearchive.com/")
- (synopsis "Follow-the-mouse X demo")
- (description "Xeyes is a demo program for x.org. It shows eyes
-following the mouse.")
- (license license:x11)))
-
-
-(define-public pixman
- (package
- (name "pixman")
- (version "0.32.4")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://cairographics.org/releases/pixman-"
- version
- ".tar.gz"))
- (sha256
- (base32
- "113ycngcssbrps217dyajq96hm9xghsfch82h14yffla1r1fviw0"))))
- (build-system gnu-build-system)
- (inputs
- `(("libpng" ,libpng)
- ("zlib" ,zlib)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (home-page "http://www.pixman.org/")
- (synopsis "Low-level pixel manipulation library")
- (description "Pixman is a low-level software library for pixel
-manipulation, providing features such as image compositing and trapezoid
-rasterisation.")
- (license license:x11)))
-
-
-(define-public libdrm
- (package
- (name "libdrm")
- (version "2.4.46")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://dri.freedesktop.org/libdrm/libdrm-"
- version
- ".tar.bz2"))
- (sha256
- (base32
- "1wah4qmrrcv0gnx65lhrlxb6gprxch92wy8lhxv6102fml6k5krk"))))
- (build-system gnu-build-system)
- (inputs
- `(("libpciaccess" ,libpciaccess)
- ("libpthread-stubs" ,libpthread-stubs)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (home-page "http://dri.freedesktop.org/wiki/")
- (synopsis "Direct rendering userspace library")
- (description "The Direct Rendering Infrastructure, also known as the DRI,
-is a framework for allowing direct access to graphics hardware under the
-X Window System in a safe and efficient manner. It includes changes to the
-X server, to several client libraries, and to the kernel (DRM, Direct
-Rendering Manager). The most important use for the DRI is to create fast
-OpenGL implementations providing hardware acceleration for Mesa.
-Several 3D accelerated drivers have been written to the DRI specification,
-including drivers for chipsets produced by 3DFX, AMD (formerly ATI), Intel
-and Matrox.")
- (license license:x11)))
-
-
-;; old version, required by old mesa, see
-;; http://www.mail-archive.com/nouveau@lists.freedesktop.org/msg10098.html
-(define-public libdrm-2.4.33
- (package (inherit libdrm)
- (version "2.4.33")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://dri.freedesktop.org/libdrm/libdrm-"
- version
- ".tar.bz2"))
- (sha256
- (base32
- "1slgi61n4dlsfli47ql354fd1ppj7n40jd94wvnsdqx0mna9syrd"))))
- (arguments
- `(#:configure-flags
- ;; create libdrm_nouveau.so, needed by mesa, see
- ;; http://comments.gmane.org/gmane.linux.lfs.beyond.support/43261
- `("--enable-nouveau-experimental-api")))))
-
-
-(define-public mtdev
- (package
- (name "mtdev")
- (version "1.1.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://bitmath.org/code/mtdev/mtdev-"
- version ".tar.bz2"))
- (sha256
- (base32
- "159ndzwfpw0xr8mw4lhl47w9c2krshlfrscs7k6n186vknv2hk3d"))))
- (build-system gnu-build-system)
- (home-page "http://bitmath.org/code/mtdev/")
- (synopsis "Multitouch protocol translation library")
- (description "Mtdev is a stand-alone library which transforms all
-variants of kernel MT events to the slotted type B protocol. The events
-put into mtdev may be from any MT device, specifically type A without
-contact tracking, type A with contact tracking, or type B with contact
-tracking.")
- (license license:x11)))
-
-
;; packages without propagated input
;; (rationale for this separation: The packages in PROPAGATED_INPUTS need to
@@ -1297,7 +1160,8 @@ autotools system.")
(base32
"1b8sniijb85v4my6v30ma9yqnwl4hkclci9l1hqxnipfyhl4sa9j"))))
(build-system gnu-build-system)
- (inputs
+ (propagated-inputs
+ ;; xcomposite.pc refers to all these.
`(("xproto" ,xproto)
("libxfixes" ,libxfixes)
("libx11" ,libx11)
@@ -2843,7 +2707,8 @@ kernel mode setting (KMS).")
".tar.bz2"))
(sha256
(base32
- "0hgzn1r7ig94xbr9dvq0bp1nxqlfp2ki8823jca3f22a2kf8wmg7"))))
+ "0hgzn1r7ig94xbr9dvq0bp1nxqlfp2ki8823jca3f22a2kf8wmg7"))
+ (patches (list (search-patch "xf86-video-openchrome-includes.patch")))))
(build-system gnu-build-system)
(inputs `(("libx11" ,libx11)
("libxext" ,libxext)