aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm109
1 files changed, 91 insertions, 18 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 6adf2e2fc0..2ae87a60b7 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6,7 +6,7 @@
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2015 Cyrill Schenkel <cyrill.schenkel@gmail.com>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
@@ -57,6 +57,7 @@
#:use-module (gnu packages llvm)
#:use-module (gnu packages m4)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages pciutils)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -1112,8 +1113,29 @@ themselves.")
(base32
"16dr80rdw5bzdyhahvilfjrflj7scs2yl2mmghsb84f3nglm8b3m"))))
(build-system gnu-build-system)
+ (arguments
+ '(;; Make sure libpciaccess can read compressed 'pci.ids' files as
+ ;; provided by pciutils.
+ #:configure-flags
+ (list "--with-zlib"
+ (string-append "--with-pciids-path="
+ (assoc-ref %build-inputs "pciutils")
+ "/share/hwdata"))
+
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'add-L-zlib
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Provide '-LZLIB/lib' next to '-lz' in the .la file.
+ (let ((zlib (assoc-ref inputs "zlib"))
+ (out (assoc-ref outputs "out")))
+ (substitute* (string-append out "/lib/libpciaccess.la")
+ (("-lz")
+ (string-append "-L" zlib "/lib -lz")))
+ #t))))))
(inputs
- `(("zlib" ,zlib)))
+ `(("zlib" ,zlib)
+ ("pciutils" ,pciutils))) ;for 'pci.ids.gz'
(native-inputs
`(("pkg-config" ,pkg-config)))
(home-page "https://www.x.org/wiki/")
@@ -1125,7 +1147,7 @@ themselves.")
(define-public libpthread-stubs
(package
(name "libpthread-stubs")
- (version "0.3")
+ (version "0.4")
(source
(origin
(method url-fetch)
@@ -1135,7 +1157,7 @@ themselves.")
".tar.bz2"))
(sha256
(base32
- "16bjv3in19l84hbri41iayvvg4ls9gv1ma0x0qlbmwy67i7dbdim"))))
+ "0cz7s9w8lqgzinicd4g36rjg08zhsbyngh0w68c3np8nlc8mkl74"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(home-page "https://www.x.org/wiki/")
@@ -1558,7 +1580,7 @@ by the legacy X11 font system.")
(define-public presentproto
(package
(name "presentproto")
- (version "1.0")
+ (version "1.1")
(source
(origin
(method url-fetch)
@@ -1568,7 +1590,7 @@ by the legacy X11 font system.")
".tar.bz2"))
(sha256
(base32
- "1kir51aqg9cwazs14ivcldcn3mzadqgykc9cg87rm40zf947sb41"))))
+ "1f96dlgfwhsd0834z8ydjzjnb0cwha5r6lxgia4say4zhsl276zn"))))
(build-system gnu-build-system)
(home-page "https://www.x.org/wiki/")
(synopsis "Xorg PresentProto protocol headers")
@@ -1819,7 +1841,7 @@ management to participate in an X11R6 session.")
(define-public util-macros
(package
(name "util-macros")
- (version "1.19.0")
+ (version "1.19.1")
(source
(origin
(method url-fetch)
@@ -1829,7 +1851,7 @@ management to participate in an X11R6 session.")
".tar.bz2"))
(sha256
(base32
- "1fnhpryf55l0yqajxn0cxan3kvsjzi67nlanz8clwqzf54cb2d98"))))
+ "19h6wflpmh7xxqr6lk5z8pds6r9r0dn7ijbvaacymx2q0m05km0q"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(arguments
@@ -2705,6 +2727,53 @@ framebuffer device.")
(license license:x11)))
+(define-public xf86-video-freedreno
+ (let ((commit "ccba8f89995de7d5e1b216e580b789c4cda05035"))
+ (package
+ (name "xf86-video-freedreno")
+ (version (string-append "1.4.0-1-" (string-take commit 7)))
+ (source
+ (origin
+ ;; there's no current tarball
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://anongit.freedesktop.org/git/xorg/"
+ "driver/xf86-video-freedreno.git"))
+ (commit commit)))
+ (sha256
+ (base32
+ "0bl9m1agi793lcddv94j8afzw1xc9w810q91mbq0n3dscbbcr9nh"))
+ (file-name (string-append name "-" version))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libdrm" ,libdrm)
+ ("mesa" ,mesa)
+ ("udev" ,eudev)
+ ("xorg-server" ,xorg-server)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ ;; This driver is only supported on ARM systems.
+ (supported-systems '("armhf-linux" "aarch64-linux"))
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--with-xorg-conf-dir="
+ (assoc-ref %outputs "out")
+ "/share/X11/xorg.conf.d"))
+ #:phases (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi")))))))
+ (home-page "https://www.x.org/wiki/")
+ (synopsis "Adreno video driver for X server")
+ (description
+ "xf86-video-freedreno is a 2D graphics driver for the Xorg X server.
+It supports a variety of Adreno graphics chipsets.")
+ (license license:x11))))
+
+
(define-public xf86-video-geode
(package
(name "xf86-video-geode")
@@ -2817,10 +2886,12 @@ X server.")
(define-public xf86-video-intel
- (let ((commit "6babcf15dd605ef40de53f5c34f95b7fd195edbe"))
+ (let ((commit "2100efa105e8c9615eda867d39471d78e500b1bb")
+ (revision "7"))
(package
(name "xf86-video-intel")
- (version (string-append "2.99.917-6-" (string-take commit 7)))
+ (version (string-append "2.99.917-" revision "-"
+ (string-take commit 7)))
(source
(origin
;; there's no current tarball
@@ -2830,7 +2901,7 @@ X server.")
(commit commit)))
(sha256
(base32
- "055v4z26r00h3mxsd084n3aq8b5h0h3jkv52xss76zgbsq3n2354"))
+ "15fg844msmixsvlxcd5wm2awmns652sxcxj2wmp6819lr32lc4ir"))
(file-name (string-append name "-" version))))
(build-system gnu-build-system)
(inputs `(("mesa" ,mesa)
@@ -3149,7 +3220,8 @@ This driver is intended for ATI Rage 128 based cards.")
".tar.bz2"))
(sha256
(base32
- "1g2r6gxqrmjdff95d42msxdw6vmkg2zn5sqv0rxd420iwy8wdwyh"))))
+ "1g2r6gxqrmjdff95d42msxdw6vmkg2zn5sqv0rxd420iwy8wdwyh"))
+ (patches (search-patches "xf86-video-siliconmotion-fix-ftbfs.patch"))))
(build-system gnu-build-system)
(inputs `(("xorg-server" ,xorg-server)))
(native-inputs `(("pkg-config" ,pkg-config)))
@@ -3743,7 +3815,7 @@ extension to the X11 protocol. It includes:
(define-public xkeyboard-config
(package
(name "xkeyboard-config")
- (version "2.20")
+ (version "2.21")
(source
(origin
(method url-fetch)
@@ -3753,7 +3825,7 @@ extension to the X11 protocol. It includes:
".tar.bz2"))
(sha256
(base32
- "0d619g4r0w1f6q5qmaqjnsc0956gi02fqgpisqffzqy4acjwggyi"))))
+ "1iffxpchy6dfgbby23nfsqqk17h9lfddlmjnhwagqag1z94p1h9h"))))
(build-system gnu-build-system)
(inputs
`(("gettext" ,gettext-minimal)
@@ -5638,14 +5710,14 @@ to answer a question. Xmessage can also exit after a specified time.")
(define-public xterm
(package
(name "xterm")
- (version "322")
+ (version "330")
(source (origin
(method url-fetch)
(uri (string-append "ftp://ftp.invisible-island.net/xterm/"
"xterm-" version ".tgz"))
(sha256
(base32
- "1mh9s5g3fs64iimnl7axk0isb5306dyshisxlv5gr8vn7ysl3nws"))))
+ "1psnfmqd23v9gxj8a98nzrgvymrk0p1whwqi92gy15bbkzrgkvks"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--enable-wide-chars" "--enable-256-color"
@@ -5708,6 +5780,7 @@ programs that cannot use the window system directly.")
(native-inputs
`(("perl-extutils-depends" ,perl-extutils-depends)
("perl-extutils-pkgconfig" ,perl-extutils-pkgconfig)
+ ("perl-module-install" ,perl-module-install)
("perl-test-deep" ,perl-test-deep)
("perl-test-exception" ,perl-test-exception)))
(propagated-inputs
@@ -5803,7 +5876,7 @@ basic eye-candy effects.")
(define-public xpra
(package
(name "xpra")
- (version "2.0.3")
+ (version "2.1.1")
(source
(origin
(method url-fetch)
@@ -5811,7 +5884,7 @@ basic eye-candy effects.")
version ".tar.xz"))
(sha256
(base32
- "1f2mkbgjslfivh5xq5xbab1cn6jjyc1d104f692f3s0dnhq7dafa"))))
+ "0fgdddhafxnpjlw5nhfyfyimxp43hdn4yhp1vbsjrz3ypfsfhxq7"))))
(build-system python-build-system)
(inputs `(("ffmpeg", ffmpeg)
("flac", flac)