summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm33
1 files changed, 12 insertions, 21 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index a029d23953..2fbacb04bd 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1084,7 +1084,7 @@ synchronization between the X server and direct-rendering clients.")
(define-public libfontenc
(package
(name "libfontenc")
- (version "1.1.3")
+ (version "1.1.4")
(source
(origin
(method url-fetch)
@@ -1094,14 +1094,14 @@ synchronization between the X server and direct-rendering clients.")
".tar.bz2"))
(sha256
(base32
- "08gxmrhgw97mv0pvkfmd46zzxrn6zdw4g27073zl55gwwqq8jn3h"))))
+ "0y90170dp8wsidr1dzza0grxr1lfh30ji3b5vkjz4j6x1n0wxz1c"))))
(build-system gnu-build-system)
(inputs
`(("zlib" ,zlib)
("xorgproto" ,xorgproto)))
(native-inputs
`(("pkg-config" ,pkg-config)))
- (home-page "https://www.x.org/wiki/")
+ (home-page "https://gitlab.freedesktop.org/xorg/lib/libfontenc")
(synopsis "Xorg font encoding library")
(description "Xorg font encoding library.")
(license license:x11)))
@@ -1271,7 +1271,7 @@ with the Cygwin XWin server when running X11 in a rootless mode.")
(define-public libxcomposite
(package
(name "libxcomposite")
- (version "0.4.4")
+ (version "0.4.5")
(source
(origin
(method url-fetch)
@@ -1281,7 +1281,7 @@ with the Cygwin XWin server when running X11 in a rootless mode.")
".tar.bz2"))
(sha256
(base32
- "0y21nfpa5s8qmx0srdlilyndas3sgl0c6rc26d5fx2vx436m1qpd"))))
+ "13sfcglvz87vl58hd9rszwr73z0z4nwga3c12rfh7f5s2ln8l8dk"))))
(build-system gnu-build-system)
(propagated-inputs
;; xcomposite.pc refers to all these.
@@ -3846,7 +3846,7 @@ extension to the X11 protocol. It includes:
(define-public xkeyboard-config
(package
(name "xkeyboard-config")
- (version "2.24")
+ (version "2.26")
(source
(origin
(method url-fetch)
@@ -3856,7 +3856,7 @@ extension to the X11 protocol. It includes:
".tar.bz2"))
(sha256
(base32
- "1my4786pd7iv5x392r9skj3qclmbd26nqzvh2fllwkkbyj08bcci"))))
+ "13h3381pfp4pv32189zkfsj2x0alr91xj6dqii76rl0c8v3ihdrr"))))
(build-system gnu-build-system)
(inputs
`(("gettext" ,gettext-minimal)
@@ -5139,8 +5139,8 @@ over Xlib, including:
("xcb-util-renderutil" ,xcb-util-renderutil)
("xcb-util-wm" ,xcb-util-wm)))
(native-inputs
- `(("python" ,python-minimal-wrapper)
- ("pkg-config" ,pkg-config)))
+ `(("python" ,python-wrapper)
+ ("pkg-config" ,pkg-config)))
(arguments
`(#:parallel-tests? #f
#:configure-flags
@@ -5212,16 +5212,7 @@ draggable titlebars and borders.")
(define-public xorg-server-for-tests
(hidden-package
(package
- (inherit xorg-server)
- (version "1.20.3")
- (source (origin
- (inherit (package-source xorg-server))
- (uri (string-append
- "mirror://xorg/individual/xserver/"
- "xorg-server-" version ".tar.bz2"))
- (sha256
- (base32
- "1ph1j8gy5cazsq05krq9kppjx5v1sl75pbdka8ibxb1cq5kf8g0v")))))))
+ (inherit xorg-server))))
(define-public xorg-server-xwayland
(package
@@ -5282,7 +5273,7 @@ draggable titlebars and borders.")
(define-public libxcursor
(package
(name "libxcursor")
- (version "1.1.15")
+ (version "1.2.0")
(source
(origin
(method url-fetch)
@@ -5292,7 +5283,7 @@ draggable titlebars and borders.")
".tar.bz2"))
(sha256
(base32
- "0syzlfvh29037p0vnlc8f3jxz8nl55k65blswsakklkwsc6nfki9"))))
+ "10l7c9fm0jmpkm9ab9dz8r6m1pr87vvgqjnbx1psz50h4pwfklrs"))))
(build-system gnu-build-system)
(propagated-inputs
`(("libx11" ,libx11)