summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm28
1 files changed, 20 insertions, 8 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 2fbacb04bd..6471f2d630 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1212,7 +1212,7 @@ hit when running single-threaded.")
(define-public libsm
(package
(name "libsm")
- (version "1.2.2")
+ (version "1.2.3")
(source
(origin
(method url-fetch)
@@ -1222,7 +1222,7 @@ hit when running single-threaded.")
".tar.bz2"))
(sha256
(base32
- "1gc7wavgs435g9qkp9jw4lhmaiq6ip9llv49f054ad6ryp4sib0b"))))
+ "1fwwfq9v3sqmpzpscymswxn76xhxnysa24pfim1mcpxhvjcl89id"))))
(build-system gnu-build-system)
(propagated-inputs
`(("libice" ,libice))) ; SMlib.h includes ICElib.h
@@ -2399,6 +2399,18 @@ XC-APPGROUP, XTEST.")
(base32
"0xca343ff12wh6nsq76r0nbsfrm8dypjrzm4fqz9vv9v8i8kfrp1"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-before 'configure 'pedantry
+ (lambda _
+ ;; XXX: libevdev includes kernel headers, which causes this
+ ;; compile test to fail with:
+ ;; ...-headers-4.14.67/include/asm-generic/posix_types.h:88:14:
+ ;;error: ISO C90 does not support ‘long long’ [-Werror=long-long]
+ (substitute* "test/Makefile.in"
+ (("-pedantic -Werror -std=c89")
+ "-pedantic -Werror -std=c99"))
+ #t)))))
(native-inputs `(("python" ,python)))
(home-page "https://www.freedesktop.org/wiki/Software/libevdev/")
(synopsis "Wrapper library for evdev devices")
@@ -4520,7 +4532,7 @@ cannot be adequately worked around on the client side of the wire.")
(define-public libxdamage
(package
(name "libxdamage")
- (version "1.1.4")
+ (version "1.1.5")
(source
(origin
(method url-fetch)
@@ -4530,7 +4542,7 @@ cannot be adequately worked around on the client side of the wire.")
".tar.bz2"))
(sha256
(base32
- "1bamagq7g6s0d23l8rb3nppj8ifqj05f7z9bhbs4fdg8az3ffgvw"))))
+ "0igaw2akjf712y3rv7lx473jigxmcv9rs9y8sbrvbhya8f30cd5p"))))
(build-system gnu-build-system)
(propagated-inputs
;; These are all in the Requires or Requires.private field of xdamage.pc
@@ -4822,7 +4834,7 @@ common definitions and porting layer.")
(define-public libxau
(package
(name "libxau")
- (version "1.0.8")
+ (version "1.0.9")
(source
(origin
(method url-fetch)
@@ -4832,7 +4844,7 @@ common definitions and porting layer.")
".tar.bz2"))
(sha256
(base32
- "1wm4pv12f36cwzhldpp7vy3lhm3xdcnp4f184xkxsp7b18r7gm7x"))))
+ "1v3krc6x0zliaa66qq1bf9j60x5nqfy68v8axaiglxpnvgqcpy6c"))))
(build-system gnu-build-system)
(propagated-inputs
`(("xorgproto" ,xorgproto)))
@@ -5238,7 +5250,7 @@ draggable titlebars and borders.")
(define-public libx11
(package
(name "libx11")
- (version "1.6.6")
+ (version "1.6.7")
(source
(origin
(method url-fetch)
@@ -5248,7 +5260,7 @@ draggable titlebars and borders.")
".tar.bz2"))
(sha256
(base32
- "0ks1mxlda7nxfmffihi15ljsn50q8dknl33i2xag8xzc80fiizk5"))))
+ "0j0k5bjz4kd7rx6z09n5ggxbzbi84wf78xx25ikx6jmsxwq9w3li"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;8 MiB of man pages + XML