aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm54
1 files changed, 34 insertions, 20 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 0d3cdce37c..00f975bf65 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -999,7 +999,7 @@ authentication records.")
(define-public inputproto
(package
(name "inputproto")
- (version "2.3.1")
+ (version "2.3.2")
(source
(origin
(method url-fetch)
@@ -1009,7 +1009,7 @@ authentication records.")
".tar.bz2"))
(sha256
(base32
- "1lf1jlxp0fc8h6fjdffhd084dqab94966l1zm3rwwsis0mifwiss"))))
+ "07gk7v006zqn3dcfh16l06gnccy7xnqywf3vl9c209ikazsnlfl9"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(home-page "https://www.x.org/wiki/")
@@ -1432,7 +1432,7 @@ treat it as part of their software base when porting.")
"07041q4k8m4nirzl7lrqn8by2zylx0xvh6n0za301qqs3njszgf5"))))
(build-system gnu-build-system)
(inputs
- `(("gettext" ,gnu-gettext)
+ `(("gettext" ,gettext-minimal)
("libxt" ,libxt)
("xproto" ,xproto)
("libxext" ,libxext)))
@@ -1920,7 +1920,7 @@ generate new versions of their configure scripts with autoconf.")
(define-public videoproto
(package
(name "videoproto")
- (version "2.3.2")
+ (version "2.3.3")
(source
(origin
(method url-fetch)
@@ -1930,7 +1930,7 @@ generate new versions of their configure scripts with autoconf.")
".tar.bz2"))
(sha256
(base32
- "1dnlkd9nb0m135lgd6hd61vc29sdyarsyya8aqpx7z10p261dbld"))))
+ "00m7rh3pwmsld4d5fpii3xfk5ciqn17kkk38gfpzrrh8zn4ki067"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(home-page "https://www.x.org/wiki/")
@@ -3675,7 +3675,7 @@ alternative implementations like XRandR or TwinView.")
(define xkbcomp-intermediate ; used as input for xkeyboard-config
(package
(name "xkbcomp-intermediate")
- (version "1.3.0")
+ (version "1.3.1")
(source
(origin
(method url-fetch)
@@ -3684,8 +3684,8 @@ alternative implementations like XRandR or TwinView.")
version
".tar.bz2"))
(sha256
- (base32
- "0aibcbhhjlwcrxh943xg2dswwx5bz1x0pmhs28b55gzsg0vrgb6g"))))
+ (base32
+ "0gcjy70ppmcl610z8gxc7sydsx93f8cm8pggm4qhihaa1ngdq103"))))
(build-system gnu-build-system)
(inputs
`(("xproto" ,xproto)
@@ -3789,7 +3789,7 @@ extension to the X11 protocol. It includes:
(define-public xkeyboard-config
(package
(name "xkeyboard-config")
- (version "2.17")
+ (version "2.18")
(source
(origin
(method url-fetch)
@@ -3799,10 +3799,10 @@ extension to the X11 protocol. It includes:
".tar.bz2"))
(sha256
(base32
- "00878f1v3034ki78pjpf2db0bh7jsmszsnxr3bf5qxripm2bxiny"))))
+ "1l6x2w357ja8vm94ns79s7yj9a5dlr01r9dxrjvzwncadiyr27f4"))))
(build-system gnu-build-system)
(inputs
- `(("gettext" ,gnu-gettext)
+ `(("gettext" ,gettext-minimal)
("libx11" ,libx11)
("xkbcomp-intermediate" ,xkbcomp-intermediate)))
(native-inputs
@@ -4008,7 +4008,7 @@ Font Description (XLFD) full name for a font.")
("libxmu" ,libxmu)
("libxrender" ,libxrender)))
(native-inputs
- `(("gettext" ,gnu-gettext)
+ `(("gettext" ,gettext-minimal)
("pkg-config" ,pkg-config)))
(home-page "https://www.x.org/wiki/")
(synopsis "Display all the characters in an X font")
@@ -4736,7 +4736,7 @@ script around the mkfontscale program.")
(define-public xproto
(package
(name "xproto")
- (version "7.0.28")
+ (version "7.0.29")
(source
(origin
(method url-fetch)
@@ -4746,7 +4746,7 @@ script around the mkfontscale program.")
".tar.bz2"))
(sha256
(base32
- "1jpnvm33vi2dar5y5zgz7jjh0m8fpkcxm0f0lbwfx37ns5l5bs19"))))
+ "12lzpa9mrzkyrhrphzpi1014np3328qg7mdq08wj6wyaj9q4f6kc"))))
(build-system gnu-build-system)
(propagated-inputs
`(("util-macros" ,util-macros))) ; to get util-macros in (almost?) all package inputs
@@ -4823,7 +4823,7 @@ an X Window System display.")
(define-public libxfixes
(package
(name "libxfixes")
- (version "5.0.1")
+ (version "5.0.2")
(source
(origin
(method url-fetch)
@@ -4833,7 +4833,7 @@ an X Window System display.")
".tar.bz2"))
(sha256
(base32
- "0rs7qgzr6dpr62db7sd91c1b47hzhzfr010qwnpcm8sg122w1gk3"))))
+ "1slsk898386xii0r3l7szwwq3s6y2m4dsj0x93ninjh8xkghxllv"))))
(build-system gnu-build-system)
(propagated-inputs
`(("fixesproto" ,fixesproto)))
@@ -5054,7 +5054,7 @@ over Xlib, including:
(define-public xorg-server
(package
(name "xorg-server")
- (version "1.18.1")
+ (version "1.18.4")
(source
(origin
(method url-fetch)
@@ -5063,7 +5063,7 @@ over Xlib, including:
name "-" version ".tar.bz2"))
(sha256
(base32
- "17bq40als48v12ld81jysc0gj5g572zkjkyzbhlm3ac9xgdmdv45"))))
+ "1j1i3n5xy1wawhk95kxqdc54h34kg7xp4nnramba2q8xqfr5k117"))))
(build-system gnu-build-system)
(propagated-inputs
`(("dri2proto" ,dri2proto)
@@ -5112,7 +5112,13 @@ over Xlib, including:
("xkbcomp" ,xkbcomp)
("xkeyboard-config" ,xkeyboard-config)
("xtrans" ,xtrans)
- ("zlib" ,zlib)))
+ ("zlib" ,zlib)
+ ;; Inputs for Xephyr
+ ("xcb-util" ,xcb-util)
+ ("xcb-util-image" ,xcb-util-image)
+ ("xcb-util-keysyms" ,xcb-util-keysyms)
+ ("xcb-util-renderutil" ,xcb-util-renderutil)
+ ("xcb-util-wm" ,xcb-util-wm)))
(native-inputs
`(("python" ,python-minimal-wrapper)
("pkg-config" ,pkg-config)))
@@ -5128,9 +5134,17 @@ over Xlib, including:
(string-append "--with-xkb-bin-directory="
(assoc-ref %build-inputs "xkbcomp")
"/bin")
+ ;; By default, it ends up with invalid '${prefix}/...', causes:
+ ;; _FontTransOpen: Unable to Parse address ${prefix}/share/...
+ ;; It's not used anyway, so set it to empty.
+ "--with-default-font-path="
+
;; For the log file, etc.
- "--localstatedir=/var")
+ "--localstatedir=/var"
+ ;; For sddm
+ "--enable-kdrive"
+ "--enable-xephyr")
#:phases (alist-cons-before
'configure 'pre-configure