summaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm62
1 files changed, 25 insertions, 37 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 46a9a3b85f..d167269c24 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
;;; Copyright © 2015 Cyrill Schenkel <cyrill.schenkel@gmail.com>
@@ -1849,7 +1849,7 @@ management to participate in an X11R6 session.")
(define-public util-macros
(package
(name "util-macros")
- (version "1.19.1")
+ (version "1.19.2")
(source
(origin
(method url-fetch)
@@ -1859,25 +1859,26 @@ management to participate in an X11R6 session.")
".tar.bz2"))
(sha256
(base32
- "19h6wflpmh7xxqr6lk5z8pds6r9r0dn7ijbvaacymx2q0m05km0q"))))
+ "04p7ydqxgq37jklnfj18b70zsifiz4h50wvrk94i2112mmv37r6p"))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(arguments
- `(#:phases (alist-cons-after
- 'unpack 'fix-makefile-in
- (lambda _
- (substitute* "Makefile.in"
- ;; Install xorg-macros.pc in PREFIX/lib/pkgconfig,
- ;; not PREFIX/share/pkgconfig.
- (("\\$\\(datadir\\)/pkgconfig") "$(libdir)/pkgconfig")))
- (alist-cons-after
- 'install 'post-install-cleanup
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (with-directory-excursion out
- (delete-file "share/util-macros/INSTALL")
- (rmdir "share/util-macros"))))
- %standard-phases))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-makefile-in
+ (lambda _
+ (substitute* "Makefile.in"
+ ;; Install xorg-macros.pc in PREFIX/lib/pkgconfig,
+ ;; not PREFIX/share/pkgconfig.
+ (("\\$\\(datadir\\)/pkgconfig") "$(libdir)/pkgconfig"))
+ #t))
+ (add-after 'install 'post-install-cleanup
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (with-directory-excursion out
+ (delete-file "share/util-macros/INSTALL")
+ (rmdir "share/util-macros"))
+ #t))))))
(home-page "https://www.x.org/wiki/")
(synopsis "Xorg autoconf macros")
(description
@@ -2089,7 +2090,7 @@ emulate a TI-30 or an HP-10C.")
(define-public xcb-proto
(package
(name "xcb-proto")
- (version "1.12")
+ (version "1.13")
(source
(origin
(method url-fetch)
@@ -2099,10 +2100,7 @@ emulate a TI-30 or an HP-10C.")
".tar.bz2"))
(sha256
(base32
- "01j91946q8f34l1mbvmmgvyc393sm28ym4lxlacpiav4qsjan8jr"))
- (patches
- (search-patches "xcb-proto-python3-whitespace.patch"
- "xcb-proto-python3-print.patch"))))
+ "1qdxw9syhbvswiqj5dvj278lrmfhs81apzmvx6205s4vcqg7563v"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config) ("python" ,python-minimal-wrapper)))
@@ -2767,11 +2765,7 @@ framebuffer device.")
`(#:configure-flags
(list (string-append "--with-xorg-conf-dir="
(assoc-ref %outputs "out")
- "/share/X11/xorg.conf.d"))
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
- (lambda _
- (zero? (system* "autoreconf" "-vfi")))))))
+ "/share/X11/xorg.conf.d"))))
(home-page "https://www.x.org/wiki/")
(synopsis "Adreno video driver for X server")
(description
@@ -2926,11 +2920,7 @@ X server.")
(string-prefix? "x86_64-" system)))
%supported-systems))
(arguments
- '(#:configure-flags '("--with-default-accel=uxa")
- #:phases (modify-phases %standard-phases
- (add-after 'unpack 'bootstrap
- (lambda _
- (zero? (system* "autoreconf" "-vfi")))))))
+ '(#:configure-flags '("--with-default-accel=uxa")))
(home-page "https://www.x.org/wiki/")
(synopsis "Intel video driver for X server")
(description
@@ -5044,7 +5034,7 @@ protocol.")
(define-public libxcb
(package
(name "libxcb")
- (version "1.12")
+ (version "1.13")
(source
(origin
(method url-fetch)
@@ -5052,9 +5042,7 @@ protocol.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "0nvv0la91cf8p5qqlb3r5xnmg1jn2wphn4fb5jfbr6byqsvv3psa"))
- (patches
- (search-patches "libxcb-python-3.5-compat.patch"))))
+ "1ahxhmdqp4bhb90zmc275rmf5wixqra4bnw9pqnzyl1w3598g30q"))))
(build-system gnu-build-system)
(propagated-inputs
`(("libpthread-stubs" ,libpthread-stubs)